Обзор

Назначение. Возможности. Ограничения. Состав.

 Top Next

НАЗНАЧЕНИЕ

Программа DIPEdit предназначена для просмотра, обработки, корректировки и преобразования растровых файлов форматов TIF, BMP, RAW и DIP.

ВОЗМОЖНОСТИ

В программе DIPEdit реализованы следующие возможности:

1) просмотр растровых файлов форматов TIF, BMP, RAW и DIP;

2) преобразование файлов из одного формата в другой. При преобразовании в формат TIF Tiled возможно JPEG или ZIP сжатие;

3) формирование внутренней или внешней "пирамиды";

4) удаление внутренней или внешней "пирамиды";

5) выделение прямоугольного фрагмента изображения;

6) сохранение выделенного фрагмента в отдельном файле;

7) формирование гистограмм распределения яркостей по всему файлу и для выделенного фрагмента(Гистограммы);

8) гамма - коррекция изображения и каждого цветового канала;

9) коррекция контрастности изображения и каждого цветового канала;

10) коррекция яркости изображения и каждого цветового канала;

11) коррекция усиления (изменение положения правой границы яркости) изображения и каждого цветового канала;

12) сохранение всех корректировок в исходном файле;

13) измерение линейных размеров по изображению;

14) измерение яркости отдельных пикселей или распределение яркостей в выделенном фрагменте;

15) изменение масштаба просмотра изображения. Если у мыши есть колесо прокрутки, то масштаб изображения можно изменять вращением колеса при нажатой клавише <Ctrl> ;

16) формирование файла полноцветного изображения из файлов, содержащих цветовые слои(Объединить каналы...);

17) разделение файла полноцветного изображения на файлы, содержащие цветовые слои(Разделить каналы...);

18) разделение файла на части, не превышающие указанный размер (Разделить файл...);

19) формирование файла из отдельных частей(Объединить файлы...);

20) преобразование исходного файла в файл с указанным разрешением(Изменить разрешение...);

21) формирование и применение к изображению различных фильтров(Фильтр).

22) групповое открытие и обрабока файлов(Режим управления).

ОГРАНИЧЕНИЯ

Программе DIPEdit присущи следующие ограничения:

1) работа только с файлами форматов TIF, BMP, RAW и DIP;

2) цветные изображения только 24-хбитные в системе RGB.

3) размер файла не более 4 гигабайт.

СОСТАВ

Основная программа DIPEdit содержит подчиненные программы, необходимые для реализации возможностей основной программы или для запроса и формирования параметров работы. Это следующие программы:

1) программа запроса имен файлов и параметров для формирования файла полноцветного изображения из файлов, содержащих цветовые слои;

2) программа запроса имен файлов для формирования файлов, содержащих цветовые слои из файла полноцветного изображения;

3) программа для цветовой коррекции изображения и каждого из цветовых каналов;

4) программа отображения и анализа гистограмм;

5) программа для запроса параметров преобразования изображения открытого файла в файл с другим разрешением;

6) программа для создания фильтров и применения их к изображению;

7) программа для индикации выполнения процесса;

8) программа определения и установки режимов работы с изображениями.

СОКРАЩЕНИЯ

TIFF(TIF) - Tag Image File Format - файловый формат для хранения растровых образов.

BMP - Bit MaP - файловый формат для хранения растровых образов.

DIP - Digital Image of Photo - файловый формат для хранения восьмибитных изображений в градациях серого.

DPI - число пикселей на дюйм (единица разрешения растрового изображения).

Форма - отдельное окно на экране, формируемое для запроса параметров или выполнения определенных действий.

"Пирамида" - изображения меньшего разрешения относительно основного, добавленные в растровый файл для реализации быстрого изменения масштаба изображения.


Разделы

Головное меню. Разделы

 Top Previous Next

Головное меню формы DIPEdit содержит следующие разделы:

Файл Вид Изображение Фрагмент Сервис Доступ Помощь

.


Раздел Файл

Раздел Файл содержит следующие пункты:

Открыть - вызывает стандартный диалог Windows для открытия одного или нескольких файлов.

Закрыть - закрывает открытый файл.

Сохранить - сохраняет все изменения в исходном файле.

Сохранить как... - вызывает стандартный диалог Windows для открытия файла, в который будет сохранятся текущий файл. Файл будет преобразован в формат, соответствуующий расширению нового имени.

Переименовать... - позволяет переименовать файл просматриваемого изображения. Это дает возможность оперативно привести в соответствие номер снимка и имя файла. Нажатие клавиш Ctrl+R дублирует действие этого пункта.

Закрыть все - закрывает все открытые файлы.

Сохранить все - сохраняет все изменения для всех открытых файлов.

Сохранить все как... - запрашивается только формат для сохранения всех открытых файлов. Все открытые файлы, формат которых не совпадает с указанным, будут преобразованы в указанный формат. Сохраненным файлам назначаются имена исходных файлов. Если указан режим сохранения без удаления исходных файлов и имя исходного файла совпадает с именем сохраненного, к имени исходного файла добавляется расширение .BAK. При включенном флажке "Полноцветные в 256 цветов" все полноцветные растры (24 бит на пиксел) формата TIF с помощью создания адаптивной палитры цветов будут преобразованы в 256-ти цветные (8 бит на пиксел).

Разделить каналы... - для открытого полноцветного файла сформировать файлы цветовых слоев. Вызывает форму для определения имен файлов для цветовых слоев (см. Разделение каналов).

Объединить каналы... - вызывает форму для определения имен файлов с цветовыми слоями изображения, имени файла для полноцветного изображения и параметров слияния. Из файлов цветовых слоев формируется файл полноцветного изображения (см. Объединение каналов).

Разделить файл... - разрезать открытый файл на части.

Объединить файлы... - склеить файл из частей.

Объединить Quickbird файлы... - объединить Quickbird файлы в один файл. Для поставки большого изображения на компакт дисках оно разбивается на относительно небольшие фрагменты. Работать с такими фрагментами неудобно. Для объединения файлов используется описание всего изображения из файла *.IMD и описание частей и их расположение из файла *.TIL. При этом сохраняется привязка изображения к местности, указанная в файле *.IMD.

Выход - завершает работу формы.

Пункты Открыть и Сохранить дублируются кнопками на линейке инструментов.

В разделе Файл содержится список, в котором хранятся до восьми имен файлов, которые открывались последними. Щелчок левой кнопки мыши на любом имени в списке приводит к открытию соответствующего файла.


Раздел Вид

Раздел View(Вид) содержит следующие пункты:

Неразвернутый - просмотр исходного неразвернутого изображения.

Развернутый на 90° - изображение развернуто на 90° по часовой стрелке.

Развернутый на -90° - изображение развернуто на 90° против часовой стрелки.

Развернутый на 180° - изображение развернуто на 180°.

Устранить виньетирование - вызывает окно для установки параметров и просмотра результатов устранения виньетирования (убываения яркости снимка от центра к периферии). Убывание яркости происходит по закону cos(R)**k, где R - расстояние точки снимка от центра снимка, а k - показатель степени косинуса. В окне необходимо указать величину фокусного расстояния фотоаппарата и величину степени k(1-5). Флажок 'Контраст' к изменению яркости включает изменение контраста, что позволяет устранять цветовое пятно в центре цветного снимка. Флажок "Просмотр" включает/отключает просмотр результата устранения виньетирования. Кнопка "Ok" фиксирует применение операции. При включенном режиме групповой обработки устранение виньетирования будет применяться ко всем открытым файлам. Кнопка "Отменить" отключает применение устранения виньетирования.

Установить позицию F3 - включает/отключает режим определения текущей точки изображения. При включенном режиме перемещает указанную курсором точку изображения в центр окна просмотра. Отключается режим нажатием клавиши <Esc>.

Сохранить позицию F4 - запомнить текущую позицию просматриваемого изображения. Позиция запоминается в файле DIPEdit.ini. Это позволит вернуть изображение в эту позицию как в текущем сеансе работы с программой, так и в других сеансах.

Вернуться в позицию F5 - установить изображение в позицию, запомненную с помощью предыдущего пункта. Если сохранение позиции не производилось, то изображение устанавливается в позицию (0,0).

Канал - для цетных (RGB) изображений вызывает подменю с выбором для отображения всего изображения или его цветовых каналов:

Все - отображается полоноцветное изображение. Дублируется нажатием клавиш Ctrl+4;

Красный - отображается полоноцветное изображение. Дублируется нажатием клавиш Ctrl+1;

Зеленый - отображается полоноцветное изображение. Дублируется нажатием клавиш Ctrl+2;

Синий - отображается полоноцветное изображение. Дублируется нажатием клавиш Ctrl+3;

Панель пиктограмм - Включает/отключает отображение панели пиктограм изображений.


Раздел Изображение

Раздел Изображение содержит следующие пункты:

Откат <...> - позволяет отменить действие пунктов Коррекция, Автовыравнивание, Эквалайзинг и Цветовой фильтр.

Гистограмма... - расчитывает гистограмму распределения яркостей всего изображения или выделенного фрагмента. Для полноцветного изображения расчитывает гистограммы распределения яркостей в цветовых слоях. Вызывает форму для отображения гистограмм (см. Гистограммы).

Коррекция - вызывает форму расширенной коррекции полноцветных изображений (см. Расширенная коррекция).

Коррекция по гистограмме... - вызывает форму коррекции изображений с использованием их гистограммы (см. Коррекция по гистограмме).

Цветовой диапазонный фильтр - вызывает окно цветовой фильтрации для полноцветного файла.

Копировать - копирует открытое изображение текущего масштаба в буфер обмена. Горячие клавиши - Ctrl+Ins.

Автовыравнивание - коррекция тональности изображения с помощью нелинейного преобразования гистограммы.

Эквалайзинг - преобразует гистограмму яркостей в близкую к равномерному закону распределения.

Инверсия - инвертирует отображение файла. Дублируется клавишей <*>(звездочка).

Определение параметров полос - определение параметров преобразования для устранения вертикальных полос на изображении, возникших из-за рассеяния освещения при сканировании.

Устранение полос - преобразование изображения для устранения вертикальных полос. Для преобразования используются параметры группы 'ПЗС линейка' окна Настройки:

размер ПЗС линейки сканера, пикселей;

размер одного пикселя ПЗС линейки, мкм;

направление сканирования снимка.

Подбор параметров для устранения полос выполняется в отдельном окне, которое появляется при выборе этого пункта.

Удаление царапин - удаление царапин, пыли и следов загрязнений для цветного изображения с помощью изображения, полученного в инфракрасном диапазоне. Параметры, необходимые для этого, указываются в окне Настройки.

Изменить размер пиксела... - позволяет изменить размер пиксела в заглавии файла. При этом весь файл не преобразуется к новому разрешению. Дублируется клавишей F12.

Свойства - отображает форму с перечнем свойств изображения (наименование, формат и размер файла, размер пиксела, наличие пирамиды и пр.).


Раздел Фрагмент

Раздел Фрагмент содержит следующие пункты:

Определить фрагмент - переводит программу в режим определения фрагмента изображения. Курсор принимает форму перекрестия. Мышкой установить курсор в точку начала фрагмента, нажать левую клавишу мыши, удерживая ее нажатой, перемещать курсор до завершения формирования нужного фрагмента и отпустить клавишу мышки. Отпускание клавиши мышки служит сигналом для завершения режима определения фрагмента. Определение нового фрагмента отменяет предыдущий фрагмент.

Сохранить фрагмент - сохраняет выделенный фрагмент изображения в указанном файле. Вызывает стандартный диалог Windows для определения имени файла фрагмента.

Выравнивание тональности... - вызывает форму для определения параметра выравнивания тональности и выполняет сохранение фрагмента с выравниванием тональности.

Статистика - формирует информацию о распределении яркостей в фрагменте и вызывает форму для отображения этой информации.

Распечатать фрагмент - вывод выделенного фрагмента на принтер или плоттер.

Отменить фрагмент - отменяет выделение фрагмента и удаляет прямоугольник его выделяющий.

Этот раздел головного меню дублируется всплывающим меню, которое вызывается щелчком правой клавиши мышки в окне изображения.


Раздел Сервис

Раздел Сервис содержит следующие пункты:

Создать пирамиду - создает изображения более низкого разрешения и добавляет их в открытый файл. Тип пирамиды (внутренняя или внешняя) и метод создания (быстрый 2х2, гауссиан 3х3, гауссиан 5х5) определяются в настройках программы (Сервис|Настройки).

Удалить пирамиду - отсекает часть файла, содержащую изображения более низкого разрешеения.

Повернуть на - позволяет повернуть изображение на указанный угол. Подменю этого пункта реализует следующие повороты: на 90,180 и 270 градусов; на произвольный указанный угол; зеркальный по X; зеркальный поY.

Повернуть линию - позволяет повернуть изображение до горизонтального положения указанной линии. При выборе этого пункта программа входит в режим "Измерения" (см. ниже). После регистрации второй точки линии на изображении программа определяет угол поворота изображения и выполняет пункт "Повернуть на"(см. выше).

Выравнивание тональности... - вызывает форму для определения параметра выравнивания тональности и выполняет сохранение изображения с выравниванием тональности. Флажок Preview(Просмотр) позволяет применить выравнивание к части изображения, видимого на экране и оценить качество выравнивания.

Изменить разрешение... - вызывает форму для определения нового разрешения изображения, определяет новый размер пикселя и формирует новый файл с указанным разрешением изображения (см. Изменение разрешения).

Фильтр... - вызывает форму для выбора фильтра и формирования изображения с применением фильтра (см. Фильтр).

Отчет о гистограмме - формирует текстовый файл с параметрами гистограммы для открытого растрового файла (если не включен групповой режим обработки файлов). Имя файла отчета совпадает с именем растрового файла. Расширение файла <.txt>. Файл создается в папке, содержащей растровый файл. Если в установках программы включен флажок "Формировать BMP файл", создается BMP файл с изображением гистограммы. Имя файла совпадает с именем растрового файла, к которому добавлено <-Hist.bmp>. Файл создается в папке, содержащей растровый файл. Если включен групповой режим обработки файлов, создаются файлы отчетов для всех открытых растровых файлов.

Измерения - включает режим измерения яркости пикселей и линейных размеров объектов на растре (см. Режим управления). Отклается режим измерений нажатием клавиши <Esc>.

Регистрация точки - позволяет зарегистрировать на изображении нужные точки, указать их идентификаторы и запомнить эту информацию в файле изображения. Эта возможность доступна только для файлов формата TIF и DIP. Зарегистрированные точки будут отображаться при включенной опции "Показывать точки на растре" (см. Установки). При выборе этого пункта включается режим активного управления изображением и появляется изображение марки (цвет иформу марки можно изменят, см. Режим управления). Для регистрации точки необходимо с помощью мышки переместить марку в нужную точку и нажать левую клавишу мыши. В появившемся окне указать идентификатор зарегистрированной точки. При нажатии кнопки Ok координаты точки будут занесены в файл. при нажатии кнопки Cancel(Отменить) точка игнорируется. Прервать процесс регистрации можно нажатием клавиши <Esc>.

Удалить все точки - удаляет информацию о всех зарегистрированных точках.

Удалить точку - удаляет информацию о зарегистрированной точке, идентификатор которой запрашивается.

Макро... - вызывает форму для создания, корректировки и выполнения макросов (последовательное выполнение нескольких команд для открытых файлов или для всех растровых файлов в указанной папке - Макро).

Настройки... - вызывает форму для определения режимов работы программы.


Раздел Доступ

Раздел Доступ содержит следующие пункты:

Войти... - запрос пароля для входа в систему управления правами доступа к открытым файлам.

Установить список ключей... - вызывает окно для формирования списка электронных ключей защиты, для которых разрешен доступ к открытым растровым файлам.

Термины.

Исходное состояние растрового файла - состояние без ограничения доступа.

Защищеное состояние растрового файла - доступ ограничен списком номеров электронных ключей.

Защитить можно только файлы в формате TIFF Tiled(блочный TIFF). Пароль и список ключей записываются в заглавие файла. После этого файлы можно переносить на другие компьютеры, переписывать на CD и т.п. Обрабатывать защищенные файлы можно только программами пакета Delta или Digitals и только на компьютере, электронный ключ защиты программ которого есть в списке ключей защиты растрового файла.

Для перевода файлов из исходного состояния в защищенное необходимо:

1. Открыть файлы, находящиеся в исходном состоянии.

2. Выполнить пункт Войти... и указать пароль для управления правом доступа к открытым файлам. Для пароля можно указать до 8-ми произвольных знаков. Пароль чувствителен к регистру.

3. Выполнить пункт Установить список ключей... В появившемся окне указать перечень номеров электронных ключей защиты, с которыми будет разрешен доступ к открытым файлам.

4. Подтвердить указанный пароль.

5. Нажать кнопку "Ок" для занесения пароля и списка ключей в открытые файлы. Итоги выполнения будут показаны в отдельном окне.

Для изменения списка ключей в защищенных файлах необходимо:

1. Открыть файлы, защищенные одинаковым паролем.

2. Выполнить пункт Войти... и указать пароль для управления правом доступа к открытым файлам.

3. Выполнить пункт Установить список ключей... В появившемся окне изменить перечень номеров электронных ключей защиты, с которыми будет разрешен доступ к открытым файлам.

4. Нажать кнопку "Ок" для занесения нового списка ключей в открытые файлы. Итоги выполнения будут показаны в отдельном окне.

Для снятия защиты с файлов необходимо:

1. Открыть файлы, защищенные одинаковым паролем.

2. Выполнить пункт Войти... и указать пароль для управления правом доступа к открытым файлам.

3. Выполнить пункт Установить список ключей... В появившемся окне удалить весь перечень номеров электронных ключей защиты.

4. Нажать кнопку "Ок" для удаления списка ключей в открытых файлах. Итоги выполнения будут показаны в отдельном окне.

Внимание!

Для пароля можно указать до 8-ми произвольных знаков. Пароль чувствителен к регистру.

Храните и помните пароль. Без правильного пароля нельзя изменить список ключей доступа и нельзя снять защиту с файлов, защищенных этим паролем.

Примечания.

1. Защищенные файлы нельзя сконвертировать в другие форматы, потому что это привело бы к снятию защиты.

2. Рекомендуется предварительную обработку файлов (радиометрическую коррекцию, триангуляцию и т.п.) провести до перевода в защищенное состояние.


Раздел Помощь

Раздел Помощь содержит следующие пункты:

Содержание - вызывает систему контекстной помощи программы. Дублируется нажатием клавиши F1.

О программе... - краткая инфориация о программе и разработчиках.


Линейка инструментов

Ниже головного меню формы расположена панель - линейка инструментов. На ней расположены кнопки, дублирующие некоторые пункты головного меню:

openfil2 - дублирует действие пункта меню Файл | Открыть...

savefile - дублирует действие пункта меню Файл | Сохранить

Pyramid - дублирует действие пункта меню Сервис | Создать пирамиду

DelPyram - дублирует действие пункта меню Сервис | Удалить пирамиду

ZoomIn - используется для увеличения изображения. Дублирует действие клавиши <+> цифрового блока клавиш.

ZoomOut - используется для уменьшения изображения. Дублирует действие клавиши <-> цифрового блока клавиш.

Info - дублирует действие пункта меню Изображение | Свойства...

Fragment - дублирует действие пункта меню Фрагмент | Определить фрагмент. Остается нажатой до отмены фрагмента.

Hist - дублирует действие пункта меню Изображение | Гистограмма

QuickZ - отображает способ интерполяции пикселей для субпиксельного увеличения изображения. При отжатой кнопке используется линейная интерполяция, при нажатой - дублирование пикселей. Способ интерполяции можно установить в настройках программы (см. Настройки) или нажатием на кнопку.

Group - включает/отключает режим групповой обработки всех открытых изображений. При отжатой кнопке групповой режим отключен, при нажатой - включен (см. Настройки).

Circul - включает режим измерения яркости пикселей и линейных размеров объектов на растре (см. Режим управления). Отключается режим измерений нажатием клавиши <Esc>.

- включает/отключает режим определения текущей точки изображения. При включенном режиме перемещает указанную курсором точку изображения в центр окна просмотра. Отключается режим нажатием клавиши <Esc>.

- включает/отключает отображение полос сканирования. Параметры для отображения указываются в окне свойств (число элементов ПЗС-линейки, размер элемента линейки в мкм и направление сканирования, см. Настройки).

При установке курсора мыши на элемент линейки появляется подсказка (Hint), поясняющая роль элемента.


Строка статуса

Строка статуса находится внизу окна формы. В режиме пассивного управления она состоит из двух секций, в режиме активного управления - из пяти секций.

В последней секции указывается текущий масштаб образа на экране относительно основного изображения в файле.

Например, Zoom 2 : 1 значит, что разрешение образа на экране в 2 раза выше, чем разрешение основного изображения в файле; Zoom 1 : 2 - разрешение образа на экране в 2 раза ниже, чем разрешение основного изображения в файле.

В режиме пассивного управления в первой секции приводится информация об открытом файле (формат, размеры и т.п.).

В режиме активного управления отображается следующая информация.

Секция 1 - X координата марки (мкм) в масштабе изображения.

Секция 2 - Y координата марки (мкм) в масштабе изображения.

Начало системы координат изображения фиксируется на центральном пикселе изображения.

Секция 3 - значение яркости пиксела текущего пиксела для изображения в градациях серого или координаты цвета текущего пиксела для полноцветного изображения. Координаты цвета могут отображатся в системе координат RGB или XYZ (см. Настройки).

Секция 4 - значение длины предыдущего отрезка и текущая длина отрезка от последней точки до текущей точки (центральной точки марки). Для измерения длины отрезка необходимо в режиме активного управления мышкой переместить образ до совпадения начальной точки отрезка с центральной точкой марки и щелкнуть левой клавишей мышки, потом переместить образ до совпадения конечной точки отрезка с центральной точкой марки и снова щелкнуть левой клавишей мышки. Значение длины отрезка в мкм отобразится в секции 4.


Режим управления

Режимы управления растровым образом

Режим управления перемещением образа в окне зависит от вида выполняемой работы.

Для всех видов образ можно перемещать с помощью ползунков прокрутки, расположенных справа и внизу окна программы.

Если у мыши есть колесо прокрутки, то масштаб изображения можно изменять вращением колеса при нажатой клавише <Ctrl>.

Если курсор имеет форму руки, то образ можно перемещать, нажав левую клавишу мыши и перемещая ее в нужном направлении, не отпуская при этом клавишу мыши.

В режиме определения фрагмента (курсор - одиночное черно-белое перекрестие), регистрации точек (курсор - черно-белый кружок) и измерения линейных размеров (курсор - двойное черно-белое перекрестие) образ можно прокручивать расположив курсор близко к краю изображения (ближе 20-ти пикселей). При быстром перемещении курсора через область прокрутки за пределы окна программы прокрутка не включается.

В режиму измерения линейных размеров деталей изображения изменяется содержание строки статуса. В ней отображаются координаты центра курсора, данные о яркости пиксела, расположенного в центре курсора. Для измерения размеров необходимо переместить курсор в начальную точку и щелкнуть левой клавишей мыши. После этого переместить курсор в конечную позицию и снова щелкнуть левой клавишей. При перемещении курсора от начальной точки до конечной за курсором будет тянуться линия, а в строке статуса отображатся текущая длина линии.

Завершается режим измерений и режим регистрации точек нажатием клавиши Esc на клавиатуре.

Линейные размеры и текущие координаты марки выводятся в мкм. Начало системы координат фиксируется в центре образа.


Гистограммы

Вычисление гистограмм и активизация формы их отображения выполняется при активизации пункта головного меню Изображение | Гистограмма Если перед этим был выделен фрагмент изображения, то гистограмма вычисляется по выделенному фрагменту, иначе она формируется для всего файла. Для больших файлов (или для больших фрагментов) это может быть длительным процессом. Для прерывания формирования гистограммы необходимо нажать кнопку Отменить на форме отображения процесса. Гистограмма будет сформирована только для обработанной части файла.

Для изображений в градациях серого формируется только одна гистограмма - распределение яркостей. Для полноцветных изображений формируется 5 гистограмм: яркости(Luminosity), суммарная каналов(RGB), красного канала(Red), зеленого канала(Green) и синего канала(Blue). Выпадающий список позволяет указать отображение гистограммы конкретного канала или 4-х каналов одновременно: 3 цветовых и яркостный или суммарный (в зависимости от того, который из них вызывался последним). Для каждой гистограммы вычисляются следующие данные: среднее значение, среднее квадратическое отклонение и медиана. При перемещении курсора мышки в окно гистограммы отображается текущее положение курсора(текущая яркость), число пикселей этой яркости и процент пикселей до текущей позиции от общего числа пикселей.

Гистограмма формируется и отображается для каждого открытого файла при его активизации. При нажатии на форме отображения гистограмм кнопки "Отчет" формируется два файла: текстовый файл, в котором записаны характеристики гистограммы, и растровый файл в формате BMP c изображениями гистограмм. Файлы формируются в папке с исходным файлом. Текстовый файл имеет расширение имени ".txt", а для растрового файла к имени исходного файла добавляется

"-Hist.bmp".


Фильтр

Активизация формы для работы с фильтром выполняется при активизации пункта головного меню Сервис | Фильтр. Эта форма позволяет сформировать новый фильтр, запомнить его в файл, прочитать из файла готовый фильтр, просмотреть влияние фильтра на изображение и применить выбранный фильтр к исходному файлу изображения. При применении фильтра к исходному файлу его содержание измениться в соответствии с фильтром. Для сохранения оригинального изображения необходимо выполнить копирование исходного файла перед применением фильтра.


Цветовой диапазонный фильтр

Активизация окна для работы с фильтром выполняется при активизации пункта головного меню (Изображение | Цветовой диапазонный фильтр...).

Эта окно позволяет:

1) указать цвет фильтра при помощи стандартного диалога выбора цвета - кнопка в группе "Граничные изменения цвета, %" или выбрать цвет фильтра по исходному изображению - кнопка "Из изображения" внизу окна;

2) указать диапазон изменения цвета фильтра в процентах от максимального значения яркости(255). Индикаторы выше и ниже кнопки выбора цвета фильтра в группе "Граничные изменения цвета, %" отображают граничные значения цвета фильтра. Диапазон изменения можно задать при помощи ползунка или поля редактирования справа от него;

3) указать диапазон изменения цвета фильтра в каждом цветовом канале фильтра - группа "Граничные изменения поканально, %";

4) указать цвет для пикселей, которыу прошли через фильтр - кнопка "Цвет изображения". Этот цвет будет устанавливаться при включенном флаге "Использовать".

5) указать цвет для пикселей, который не прошли через фильтр - кнопка "Цвет фона". По умолчанию цвет фона - белый;

6) результаты применения фильтра отображаются в окне просмотра, ниже которого расположена панель с кнопками <+> и <-> для изменения и отображения текущего масштаба в окне просмотра. При нажатии левой клавиши мышки на основном изображении в окне просмотра отображается фрагмент изображения вокруг точки нажатия.

7) просмотреть результат применения фильтра к основному изображению - установить флаг "Просмотр";

8) если в программе открыто несколько цветных изображений, то при переключении изображений фильтр отображает результат применения к текущему изображению.

При нажатии кнопки "Ok" фильтр применяется к основному изображению, а окно фильтра закрывается. Для отмены действия фильтра можно выполнить команду "Изображение | Откат Цветовой фильтр" или снова вызвать форму для работы с цветовым фильтром и нажать кнопку "Отменить".

Кнопка "Отменить" служит для отмены действия цветового фильтра при выходе из формы.


Разделение каналов

Разделение цветовых каналов

Для открытого полноцветного файла можно сформировать файлы, содержащие цветовые слои. Для этого необходимо активизировать пункт головного меню Файл | Разделение каналов. При этом активизируется форма определения имен для файлов цветовых слоев.

По умолчанию имена файлов слоев определяются как имя-R.ext, имя-G.ext, имя-B.ext, где имя.ext имя исходного файла. При необходимости эти имена можно изменить вызовом диалога открытия файла или набором нового имени в поле ввода соответствующего файла. Для выполнения разделения необходимо нажать кнопку Выполнить. Индикатор процесса отображает ход разделения. Прервать разделение можно нажатием кнопки Отменить. Если процесс разделения прерван по нажатию кнопки или при обнаружении ошибок чтения или записи файлов, незавершенные файлы цветовых слоев удаляются программой. Разделение каналов работает только для активного файла и не выполняется для группы файлов.


Объединение каналов

Объединение цветовых каналов

Для получения файла полноцветного изображения из файлов, содержащих цветовые слои необходимо активизировать пункт головного меню Файл | Объединить каналы. При этом активизируется форма определения имен файлов цветовых слоев, файла для результата слияния и параметров слияния. Для слияния достаточно одного или двух файлов цветовых слоев. Справа от имени каждого цветового слоя есть флажки для отметки файлов, необходимых для слияния. При послойном сканировании цветного изображения получаются цветовые слои, смещенные относительно базового слоя. Для правильного слияния таких файлов необходимо указать цвет базового слоя и число линий пикселов смещения между слоями.

Результирующий файл может быть только в формате TIF. Можно также указать порядок следования цветов каждой точки:RGB или BGR.

Если имена файлов слоев имеют форму имя-R.ext, имя-G.ext, имя-B.ext, то после определения имени файла для красного слоя и снятия фокуса ввода с поля имени программа прогнозирует имена остальных файлов слоев и файла для результата. При необходимости эти имена можно изменить вызовом диалога открытия файла или набором нового имени в поле ввода соответствующего файла. Для выполнения слияния необходимо нажать кнопку Выполнить. Индикатор процесса отображает ход слияния.

Прервать слияние можно нажатием кнопки Отменить. Если процесс слияния прерван по нажатию кнопки или при обнаружении ошибок чтения или записи файлов, незавершенный файл результата слияния удаляется программой.

После завершения слияния результирующий файл автоматически открывается для просмотра.


Разделение файла

Разделение файла на части

При необходимости файл можно разделить на части, не превышающие указанный размер. Для этого необходимо вызвать пункт меню Файл | Разделить файл. При этом вызывается форма, в которой необходимо указать базовое имя для частей разрезаемого файла, максимальный размер одного фрагмента и число частей по горизонтали или вертикали. Имя части формируется прибавлением к базовому имени номера колонки и номера в колонке, которые занимает часть изображения в целом изображении. Эти номера используются при "склейке" частей в одно изображение.


Объединение файлов

Файл, разделенный на части, можно снова "склеить". Для этого необходимо вызвать пункт меню Файл | Объединить файлы. При этом вызывается форма, в которой необходимо указать базовое имя разрезанного файла (или имя одной из частей, программа сама выделит базовое имя) и имя файла для объединения.


Расширенная коррекция

Для открытого файла можно выполнить расширенную коррекцию изображения. Для этого необходимо активизировать пункт головного меню Изображение | Коррекция...(Изображение | Коррекция). При этом активизируется форма расширенной цветовой коррекции. Она содержит 4 радиокнопки для задания корректируемого канала и 4 ползунка для гамма-коррекции, коррекции контрастности, яркости и усиления указанного канала. Кнопка Все задает синхронную коррекцию всех трех цветовых каналов для полноцветного изображения или коррекцию яркоскного канала для изображения в градациях серого. Переключение на конкретный цветовой канал(для полноцветного изображения) дает возможность корректировки только указанного канала и позволяет корректировать цветовой баланс изображения.

При нажатии на кнопку Да все результаты корректировки вступают в силу и образ в окне просмотра формируется с учетом коррекции При нажатии на кнопку Отменить все результаты текущей коррекции отменяются. При нажатии на кнопку Сброс параметры изображения устанавливаются в исходное состояние.

ВНИМАНИЕ. От файла с результатами коррекции нельзя вернуться к исходному файлу, поэтому, если Вы хотите иметь исходный файл, сохраните его до входа в форму расширенной коррекции или воспользуйтесь командой Файл | Сохранить как.... Индикатор процесса отображает ход записи результатов коррекции. Прервать процесс можно нажатием кнопки Отменить на индикаторе.


Коррекция по гистограмме

Для открытого файла можно выполнить коррекцию изображения с использованием его гистограммы. Для этого необходимо активизировать пункт головного меню (Изображение | Коррекция по гистограмме). При этом активизируется форма коррекции. Она содержит 4 радиокнопки для задания корректируемого канала и кнопку для включения/отключения гамма-коррекции. При включенной кнопке гамма-коррекции корректировка выполняется передвижением трехугольного ползунка под графиком гистограммы. При выключенной кнопке гамма-коррекции есть два трехугольных ползунка под графиком гистограммы. Они позволяют отсекать неиспользуемые участки слева и справа на графике гистограммы, что приводит к изменению радиометрических параметров изображения. На форме отображается гистограмма исходного изображения и ее изменения при корректировке изображения. Переключение на конкретный цветовой канал(для полноцветного изображения) дает возможность корректировки только указанного канала и позволяет корректировать цветовой баланс изображения.

При нажатии на кнопку Да все результаты корректировки вступают в силу и образ в окне просмотра формируется с учетом коррекции При нажатии на кнопку Отменить все результаты текущей коррекции отменяются. При включенном флажке Авто результаты коррекции сразу видны на изображении, при выключенном - только после нажатия кнопки Применить.

ВНИМАНИЕ. От файла с результатами коррекции нельзя вернуться к исходному файлу, поэтому, если Вы хотите иметь исходный файл, сохраните его до входа в форму расширенной коррекции или воспользуйтесь командой Файл | Сохранить как.... Индикатор процесса отображает ход записи результатов коррекции. Прервать процесс можно нажатием кнопки Отменить на индикаторе.


Изменение разрешения

Формирование файла с новым разрешением

Для открытого файла можно сформировать файл с другим заданным разрешением. Для этого необходимо активизировать пункт головного меню Сервис | Изменить разрешение. При этом активизируется форма определения нового разрешения файла. Новое разрешение можно задать различными способами: задать масштаб к исходному изображению, задать разрешение в DPI или задать размер пиксела нового файла в мкм. Для формирования нового файла необходимо нажать кнопку Ok, для отказа от формирования - нажать кнопку Cancel. Преобразовывается только основное изображение исходного файла, пирамида отсекается. Индикатор процесса отображает ход формирования. Прервать формирование можно нажатием кнопки Cancel на индикаторе процесса. Если процесс формирования прерван по нажатию кнопки или при обнаружении ошибок чтения или записи файлов, незавершенный файл с новым разрешением удаляется программой.


Общие положения

При сканировании снимков, распределение плотностей которых находится в узком диапазоне (противотуманные негативные и т.п.) для достижения высокого качества изображения необходимо применять большие значения контраста и экспозиции. Это приводит к появлению вертикальных или горизонтальных полос (в зависимости от направления сканирования) на однородных структурах изображения (водная гладь, большие поля, пустыня). Для устранения этих полос определяются параметры преобразование изображения. Это преобразование можно применить к отдельному файлу или в груповом режиме ко всем файлам, открытым в программе.

Для реализации устранения полос необходимо выполнить команду Сервис | Настройки и в группе параметров ПЗС линейка указать значения параметров:

Размер - число элементов ПЗС линейки, используемое для сканирования,

Пиксел - размер одного элемента ПЗС линейки в мкм,

Сканир. - из выпадающего списка выбрать направление сканирования (зависит от модели сканера).

Для определения параметров преобразования необходимо выполнить команду Изображение | Устранить полосы . Эта команда вызывает окно, назначение элементов которого приводится в пункте Интерфейс пользователя. После вызова окна программа при помощи штриховых линий показывает расположение швов между полосами сканирования. Если положение этих линий не соответствует реальному расположению швов на изображении, то необходимо припомощи команды Сервис | Настройки изменить направление сканирования так, чтобы устранить это несоответствие.

При нажатии кнопки "Ok" в этом окне параметры преобразования записываются в специальный файл на диске в папку с программой. Этот файл используется при устранении полос.

При обработке одного файла программа запросит имя выходного файла. При включеном груповом режиме необходимо указать формат выходных файлов и папку для их записи. Если папка для выходных файлов совпадает с папкой исходных файлов, для устранения совпадения имен файлов к имени исходных файлов добавляется расширение .BAK. Процесс преобразования каждого файла отображается индикатором. При нажатии кнопки Отменить на индикаторе процесс преобразования текущего и всех последующих файлов отменяется.


Технология

Режим устранения полос зависит от влючения групповой обработки открытых изображений. При включенной групповой обработке будут устранятся полосы на всех открытых изображения. При этом будут использоваться параметры коррекции, определенные на текущем изображении.

Предлагается следующая технология устранения полос.

1. Перед выполнением команды Изображение | Устранение полос включить/отключить групповой режим обработки.

2. Выполнить команду Изображение | Устранение полос. Появится окно для подбора параметров корректировки. При первой активизации окна программа устанавливает текущим первый шов, отображает границы полос штриховыми линиями и позиционирует изображение так, чтобы выбранный шов располагался в центре окна с изображением. Значения полей "Область действия ..." устанавливаются равными половине ширины полосы. Границы области действия отображаются пунктирными линиями.

3. Для цветного (RGB) изображения просмотреть цветовые каналы и установить канал для корректировки.

4. Выберать шов между полосами, неоднородность на котором наиболее типична для всех швов.

5. Используя значения полей "Перепад на шве" и "Край - середина" установить значения полей "Изменить ... на" с правильным знаком.

6. Включить флажок коррекции для текущего шва в группе "Включить коррекцию швов". Программа откорректирует изображение, используя указанные параметры для текущего шва.

Активизировать основное окно программы кликнув мышкой на нем. Просмотреть результаты коррекции и оценить качество удаления шва. Для этого можно изменять масштаб изображения, отключать и включать линии отображения полос, скроллировать изображение. Для повышения качества коррекции изменяйте границы действия коррекции текущего шва и значения для изменения яркости. Изменять границы действия можно следующими способами:

- ввести новое значение границы с клавиатуры,

- нажимать с помощью мышки синие стрелки, расположенные слева и справа полей "Область действия ...". Чем дольше удерживать стрелку нажатой, тем быстрее изменяются значения границы в поле.

- передвигать пунктирную линию границы с помощью мышки. При попадании курсора мышки близко к пунктирной линии изменяется его форма. Это значит, что нажав левую кнопку мыши и, удерживая ее нажатой, указать новое положение границы. После любого изменения параметров программа через одну секунду показывает результат коррекции изображения с новыми параметрами (если включен флажок коррекции шва).

7. После достижения необходимого качества коррекции параметры выбранного шва можно сделать стартовыми для всех швов. Для этого необходимо нажать кнопку "Применить ко всем".

8. Проверить качество коррекции всех швов. При необходимости выбрать нужный шов и повысить качество корректировки подбором индивидуальных параметров коррекции.

9. Пункты 3-8 можно выполнить для каждого цветового канала.

10. При достижении необходимого качества нажать кнопку "Ok" для сохранения параметров корректировки скорректированного изображения. При включенном групповом режиме обработки изображений эти параметры корректировки будут применены ко всем открытым в программе изображениям. Возможно, для некоторых изображений эти параметры будут не оптимальны. Повысить качество их корректировки можно индивидуальным подбором параметров.

11. Отказатся от корректировки изображения и закрыть окно подбора параметров можно с помощью нажатия кнопки "Выход".


Удаление царапин

Если цветное изображение получено сканированием фотоматериалов, содержащих много царапин и других повреждений и есть возможность получить изображение в инфракрасном диапазоне, то цветное изображение может быть исправлено с помощью вспомогательного изображения. Параметры, необходимые для этого процесса, указываются в группе Удаление царапин в окне Настройки.


Общие положения

Механизм макросов позволяет последовательно выполнить несколько действий над всеми открытыми файлами или над всеми растровыми файлами в указанной папке. Макросы записываются и хранятся в текстовом файле DIPEdit.mcr, который должен находиться в папке с программой DIPEdit.exe. Если файл макросов отсутствует, программа сама его создает и открывает пустой макрос без имени, который можно откорректировать и запомнить.

Структура макроса следующая:

Macro <Name>

Перечень действий и их параметров

End macro

Действия и параметры могут задаваться полными словами или их сокращениями. Действия, параметры и их значения могут располагатся как в одной строке, так и в нескольких строках. Нельзя только разрывать имя параметра и его значение. Для совместимости в разных WINDOWS текст макроса создается только в латинском шрифте. Регистр букв роли не играет. Разделителями между командами, параметрами и их значениями могут быть символы < >(пробел), <,>(запятая), <=>(равно) и символ табуляции. Команды

SAS OFF TIF CM JPEG QTY 90

SaveAs OutFileFormat=TIF, CompressMode=JPEG, JPEGQuality=90

SaveAs

OutFileFormat=TIF

CompressMode=JPEG

JPEGQuality=90

эквивалентны между собой по действию, но текст второго и третьего вариантов команды более понятен.

Если в процессе исполнения макроса возникает ошибка, обработка текущего файла прерывается. Все последующие файлы тоже не обрабатываются. Наиболее вероятной причиной такой ошибки является отсутствие дискового пространства для размещения новых файлов. Если очередная команда для обрабатываемого файла не имеет смысла (автовыравнивание яркости или тональности для бинарных изображений, создание внутренней пирамиды для файла неблочного формата и т.п.), признак ошибки не выставляется и такое действие для этого файла не выполняется. Это позволяет выполнить макрос для разнородных файлов.

Если в исходном файле есть пирамида изображений, то преобразование к ней не применяется и в выходной файл она не переписывается. При необходимости, последней командой макроса может быть создание пирамиды.

Выполнение каждого преобразования файла отображается в индикаторе процесса. Нажатие кнопки "Cancel" на индикаторе приведет к прекращению исполнения макроса.

После исполнения макроса формируется окно результатов, в котором отображается список всех файлов, указанных для обработки, и результат обработки каждого файла:

Yes - файл обработан успешно, если даже некоторые действия для него пропущены,

No - файл не обработан или обработан частично.


Перечень команд и параметров

Перечень возможных действий и параметров

Полное имя, сокращение Значение

============================================

SourceFolder, SF Папка - источник файлов

DestinationFolder, DF Папка - приемник файлов

CreatePyramid, CPYR Создать пирамиду изображений

StartZoom, STZ Масштаб первой ступени пирамиды (2-256)

DeletePyramid, DPYR Удалить пирамиду изображений

AutoLevels, ALV Автовыравнивание яркости

SaveAs, SAS Сохранить как...

OutFileFormat, OFF Формат файла-результата

BitsPerPixel, BPP Бит на пиксел в файле-результате

CompressMode, CM Тип сжатия файла

JPEGQuality, QTY Качество JPEG сжатия

Dodging, DG Выравнивание тональности

CorrectionLevel, CLV Уровень коррекции (0-100)

ChangePixelSize, CPS Изменить размер пиксела

NewPixelSize, NEWPS Новый размер пиксела, мкм

3x3Filter, 3X3FLT Применить фильтр

FilterName, FNM Имя файла, содержащего фильтр

Resampling, RSMP Изменить разрешение файла

Rotate, ROT Повернуть изображение

Angle Угол поворота +-(1-359)

Mirror, MRR Преобразовать зеркально

FlipGorizontal, FLIPG Зеркально по X относительно оси Y

FlipVertical, FLIPV Зеркально по Y относительно оси X

ColorFilter, CFLT Применить цветовой фильтр

FilterValue, FVAL Цвет фильтра

FilterRange, FRNG Диапазон фильтра, % (0-100)

ImageColor, IMC Цвет изображения после фильтрации

FonColor, FONC Цвет фона после фильтрации


Интерфейс пользователя

В левой части окна расположен список всех макросов в файле. Ниже списка расположены кнопки:

Удалить - для удаления из файла макроса, на котором стоит маркер в списке,

Выход - для завершения работы с макросами.

В правой части расположено окно с текстом макроса, на имени которого стоит курсор в списке макросов. Под окном с текстом макроса расположены кнопки:

Новый - для создания нового макроса,

Правка - для входа в режим редактирования макроса,

Сохранить - для сохранения в файле измененного или нового макроса,

Выполнить - для выполнения действий, указанных в макросе.

Над текстом макроса расположен выпадающий список возможных действий, параметров и их значений. Этот список помогает правильно указать текст команды или параметра или просто скопировать нужный текст в текст макроса.


Настройки

 Top Previous

Программа позволяет установить некоторые параметры, определяющие режим ее работы. Параметры эти являются общими для всех открытых изображений. Значения параметров запоминаются в файле DIPEdit.ini, который создается программой в той папке, где находится сама программа. Для просмотра или изменения значений параметров можно вызвать специальную форму при помощи команды Сервис | Настройки. Некоторые параметры можно изменить при помощи кнопок на линейке инструментов.

Возможно указать следующие параметры работы прогрммы.

Язык интерфейса: автоматически, английский, русский, испанский. При автоматическом выборе языка учитывается локализация ОС Windows: для русскоязычной Windows устанавливается русский язык интерфейса, для остальных - английский.

Старт внутренней пирамиды с 1:<n>. Указывается начальный мастаб для формирования внутренней пирамиды. Это значение высвечивается в подсказке при наведении мышки на кнопку создания пирамиды на линейке инструментов.

Автосоздание внутренней пирамиды. Внутренняя пирамида будет автоматически создаваться для новых файлов, полученных копированием или преобразованием из открытых файлов.

Использовать внешнюю пирамиду файлов. Флажок Создавать в группе Внешняя пирамида включает/отключает эту возможность. При включенном флажке кнопки и пункты меню для работы с пирамидой будут влиять только на внешнюю пирамиду. Для работы с внутренней пирамидой необходимо флажок выключить.

Внешняя пирамида нужна для некоторых программ, которые не используют внутреннюю пирамиду. Кроме того, внешнюю пирамиду можно построить для растрового файла любого формата Для создания внешней пирамиды необходимо указать количество уровней пирамиды, включая и основное изображение. Так, 10 уровней значит, что кроме основного изображения будет создано еще девять файлов, где каждое новое изображение имеет масштаб 1:2 к предыдущему. Имена файлов внешней пирамиды образуются из имени основного изображения добавлением через дефис размера пиксела в мкм. Сама программа не использует файлы внешней пирамиды для быстрого перехода к уменьшенным изображениям.

Метод создания пирамиды - задает один из методов создания пирамиды. Реализованы три метода создания пирамиды:

- быстрый 2х2. Пиксел следующего уровня равен среднему значению матрицы пикселей 2х2 предыдущего уровня.

- гауссиан 3х3. Пиксел следующего уровня равен свертке маски коэффициентов распределения Гаусса с матрицей пикселей 3х3 предыдущего уровня.

- гауссиан 5х5. Пиксел следующего уровня равен свертке маски коэффициентов распределения Гаусса с матрицей пикселей 5х5 предыдущего уровня.

Второй и третий методы более медленные и выполняют сглаживание изображения в слоях пирамиды.

Метод трансформирования пикселей - задает метод формирования пикселей нового изображения при повороте исходного изображения на угол, отличающийся от +- 90 и 180 градусов.

Из выпадающего списка можно выбрать следующие методы формирования пикселей нового изображения:

- перенос. Новый пиксел получается простым переносом соответствующего пиксела исходного преобразования;

- билинейное усреднение. Новый пиксел получается усреднением 4-х ближайших пикселей исходного изображения;

- гауссиан 3х3. Новый пиксел получается посредством преобразования матрицы 3х3 исходных пикселей через коэффициенты распределения Гаусса;

- гауссиан 5х5. Новый пиксел получается посредством преобразования матрицы 5х5 исходных пикселей через коэффициенты распределения Гаусса.

Метод переноса самый быстрый, но при его применении на прямолинейных контурах могут образовываться неровности. Методы 2-4 позволяют сглаживать эти неровности. Методы расположены по возрастанию времени преобразования. Для большинства случаев оптимальным является метод билинейного усреднения.

Цветовая система (RGB или XYZ) - задает систему координат для отображения координат цвета и информации о яркости.

Обменять каналы (Красный <----> Синий). Для цветного изображения при включенном флажке каналы красный и синий меняются местами. Это позволяет корректно просматривать файлы, созданные другими программами.

Групповая обработка (Включить/Отключить). Включается или отключается групповая обрабока всех открытых файлов. При включенном режиме групповой обработки команды конвертации, коррекции, автовыравнивания, эквалайзинга, изменения разрешения, изменения размера пиксела, выравнивания тональности, изменения масштаба отображения, фильтрации, устранения полос будут выполняться для всех открытых файлов. При отключенном режиме групповой обработки эти команды применяются только к активному открытому файлу.

Режим можно изменить при помощи кнопки на линейке инструменнтов.

Режим интерполяции:Линейная, Повтор. Задает способ интерполяции пикселей для субпиксельного увеличения изображения. При линейной интерполяции яркость новых пикселей определяется пропорционально яркости соседних пикселей, при повторе - пиксели дублируются.

Способ интерполяции можно изменить при помощи кнопки на линейке инструментов.

Параметры царапин испльзуются для устранения царапин, пыли и следов зарязнений с цветного изображения с помощью изображения, полученного в инфракрасном диапазоне. Вспомогательное изображение должно точно совпадать по ширине и высоте с основным изображением. Имя файла вспомогательного изображения образуется из имени основного изображения добавлением суффикса -IR.

Размер царапин - указывается максимальная ширина царапин в пикселах.

Количество,% - указывается в процентах приблизительное содержание царапин и других повреждений изображения.

ПЗС линейка. Указываются параметры ПЗС линейки, используемой при сканировании снимков.

Размер - число элементов линейки.

Пиксел, мкм - размер элемента линейки в мкм.

Направление - указывает направление сканирования, которое зависит от марки сканера.

Параметры используются при отображении или корректировке полос сканирования.

Параметры 16-битных растров. Для отображения растровых файлов, использующих два байта на каждый канал, уровни яркости преобразуются в 8-мибитное представление. Для этого программа использует 8 старших бит из двух байт. Если используются не все 16 бит в исходном файле и в TIF файле отсутствует описатель, указывающий максимальный уровеь белого цвета, то отображение растра на экране монитора может быть слишком темным. В таком случае можно указать число бит меньшее 16-ти. Наиболее используемые в настоящее время 12-14 бит на канал. Эта установка будет влиять на все открываемые 16-тибитные растры.

Отчет о гистограмме - флажок указывает на необходимость формирования BMP файла с изображением гистограммы при формировании текстового файла отчета о гистограмме растрового файла (Сервис|Отчет о гистограмме).


Автовыравнивание яркости

Команда позволяет изменить (выровнять) яркость изображения путем преобразования общей гистограммы изображения. Новое изображение формируется в новом файле, прит этом возможны преобразования файла, указанные в описании команды SaveAs.


 Цветовой фильтр

Цветовой фильтр

Команда используется для применения цветового диапазонного фильтра к 24-хбитным цветным изображениям. Она может использовать следующие параметры:

FilterValue=<n> или <RзначениеGзначениеBзначение> - цвет фильтра, который можно задать либо значением одинаковой яркости для всех каналов, либо значением яркости в каждом канале от 0 до 255. Значение яркости в канале должно следовать сразу после указания канала без символов-разделителей. Если параметр отсутствует, используется значение цвета фильтра по умолчанию, равное 0 (черный цвет). Это же правило действует при отсутствии значения в каком-либо канале. Запись FilterValue=<n> и FilterValue=<RnGnBn> - эквивалентны.

FilterRange=<n> или <RзначениеGзначениеBзначение> - диапазон изменения цвета фильтра в процентах от максимальной яркости в канале (255). Число n задает один диапазон изменения для всех каналов, второй способ позволяет задать разные диапазоны изменения для разных каналов. При отсутствии параметра используется значение по умолчанию, равное 5% (+-13 единиц яркости от значения цвета фильтра).

ImageColor=<n> или <RзначениеGзначениеBзначение> - цвет для точек изображения, которые прошли через фильтр. Правила формирования значения параметра аналочные с правилами для FilterValue. Если этот параметр присутствует, то всем точкам изображения, которые прошли через фильтр, будет присваиваться цвет, указанный в параметре. При отсутствии параметра цвет точек изменяться не будет.

FonColor=<n> или <RзначениеGзначениеBзначение> - цвет для точек изображения, которые не прошли через фильтр. Правила формирования значения параметра аналочные с правилами для FilterValue. Если этот параметр присутствует, то всем точкам изображения, которые не прошли через фильтр, будет присваиваться цвет, указанный в параметре. При отсутствии параметра всем точкам, не прошедшим через фильтр, будет присваиваться белый цвет (R255G255B255).

Применение цветового фильтра позволяет выделить со сканированной карты объекты определенного цвета, а при помощи параметров ImageColor и FonColor перевести их в бинарное изображение. Это особенно актуально при векторизации горизонталей (востановление рельефа).

Подобрать цветовой фильтр, значения его параметров и посмотреть результат его применения для конкретных изображений можно с помощью пункта основного меню Изображение | Цветовой диапазонный фильтр.

Новое изображение формируется в новом файле, прит этом возможны преобразования файла, указанные в описании команды SaveAs.


 Создать пирамиду

Создать пирамиду

Команда используется для создания изображений меньших масштабов. Для файлов блочных форматов (TIF Tiled, DIP) можно создавать внутреннюю пирамиду (изображения меньших масштабов находятся в одном файле с основным изображением), для файлов всех форматов - внешнюю пирамиду (создаются файлы меньших изображений).

Тип создаваемой пирамиды определяется установкой флага "Создавать" в группе "Внешняя пирамида" (пункт меню Сервис | Настройки...).

Для внутренней пирамиды можно указать параметр StartZoom=<n>, где n - масштаб первой ступени пирамиды. Если этот параметр не указан, то используется значение начальной ступени из настройки программы.

Число ступеней внешней пирамиды определяется из настройки программы.

Внутренняя пирамида создается, если в исходном изображении пирамида отсутствует, либо она начинается с другой ступени.

Наличие внешней пирамиды не проверяется.


 Удалить пирамиду

Удалить пирамиду

Команда используется для удаления пирамиды изображений. Тип удаляемой пирамиды определяется установкой флага "Создавать" в группе "Внешняя пирамида" (пункт меню Сервис | Настройки...). Если пирамида уже отсутствует, то признак ошибки не выставляется и считается, что команда выполнилась нормально.


Приемник файлов

Только три команды - ChangePixelSize(Изменить размер пиксела), CreatePyramid(Создать пирамиду) и DeletePyramid(Удалить пирамиду) не переносят содержимое исходного файла в новый файл-результат. Они только изменяют свойства исходного файла. Для остальных команд можно указать папку для формирования файлов - результатов применения команды. Для этого используется параметр DestinationFolder=<Полный путь к файлам>. Если этот параметр не указан в макросе, то файл-результат (через рабочий файл) формируется в папке исходного файла. После завершения преобразования исходный файл удаляется, а рабочий файл переименовывается в исходный. Применение параметра для указания папки с результирующими файлами позволяет сохранить исходные файлы, но потребуется дисковое пространство для размещения новых файлов.


Выравнивание тональности

Команда позволяет выровнять тональность изображения путем преобразования локальных гистограмм изображения. Это преобразование используется для выравнивания яркости в центре и на краю снимка. Команда использует параметр CorrectionLevel=<уровень коррекции от 0 до 100>. При CorrectionLevel = 0 новое изображение будет совпадать с исходным. При отсутствии параметра используется его значение по умолчанию, равное 50. Новое изображение формируется в новом файле, прит этом возможны преобразования файла, указанные в описании команды SaveAs.


 Фильтр

Фильтр

Команда используется для преобразования изображений с помощью указанного фильтра. Для выполнения команды необходимо указать параметр FilterName=<имя INI-файла, содержащего фильтр>. Файл этот должен находиться в папке, содержащей саму программу DIPEdit.exe. INI-файл с фильтром можно создать с помощью команды головного меню Сервис | Фильтр. При отсутствии параметра с именем файла фиксируется ошибка в тексте макроса и макрос исполняться не будет.

Новое изображение формируется в новом файле, прит этом возможны преобразования файла, указанные в описании команды SaveAs.


Повернуть зеркально

Команда позволяет получить зеркальное изображение. Для получения зеркального изображения по X (вращение вокруг оси Y), необходимо указать параметр FlipGorizontal(FG). Для получения зеркального изображения по Y (вращение вокруг оси X), необходимо указать параметр FlipVertical(FV). При отсутствии параметра фиксируется ошибка в тексте макроса и макрос исполняться не будет.

Необходимость зеркальных преобразований возникает при обработке изображений фототеодолитной съемки.


Изменить размер пиксела

Команда используется для изменения размера пиксела, указанного в заглавии файла. Новый файл при этом не создается. Для выполнения команды необходимо указать параметр NewPixelSize=<размер пиксела в мкм> или DPI=<число пикселей на дюйм>. При отсутствии этих параметров фиксируется ошибка в тексте макроса и макрос исполняться не будет.

При изменении размера пиксела изменятся линейные размеры изображения и координаты объектов в системе координат изображения, так как эти величины определяются через размер пиксела.


 Изменить разрешение файла

Изменить разрешение файла

Команда позволяет сформировать файл изображения с другим, заданным разрешением. Она эквивалентна пункту головного меню Сервис | Изменить разрешение (Tools | Resample). Новое разрешение можно задать задать с помощью параметра NewPixelSize=<размер пиксела в мкм> или DPI=<число пикселей на дюйм>. При отсутствии этих параметров фиксируется ошибка в тексте макроса и макрос исполняться не будет.

При изменении разрешения линейные размеры изображения и координаты объектов в системе координат изображения не изменятся.


 Повернуть изображение

Повернуть изображение

Команда позволяет получить новое изображение, повернутое относительно исходного на любой угол как по часовой, так и против часовой стрелки. Она эквивалентна пункту головного меню Сервис | Повернуть(Tools | Rotate). Для выполнения команды необходимо использовать параметр Angle=<угол в градусах>. При положительном значении угла изображение поворачивается по часовой стрелке, при отрицательном - против часовой стрелки. При отсутствии параметра фиксируется ошибка в тексте макроса и макрос исполняться не будет.


Сохранить как...

Команда позволяет создать копию файла с другим именем или преобразовать файл в другой формат. Для команды могут быть указаны следующие параметры:

OutFileFormat={Auto,TIFF,BMP,RAW,Plain} - формат выходного файла. Параметр может принимать следующие значения:

Auto - формат файла определяется по исходному файлу,

TIFF - TIFF Tiled (блочный формат),

BMP - Bit MaP,

RAW - Raw формат (Photoshop),

Plain - TIFF Plain (Striped).

CompressMode={JPEG,ZIP,None} - вид сжатия выходного файла. При отсутствии этого параметра будет использоваться вид сжатия из исходного файла (если это возможно для формата выходного файла). Значение параметра None (без сжатия) позволяет отменить сжатие выходного файла, если оно было в исходном файле. Сжатие может быть применено только к файлам формата TIFF Tiled.

JPEGQuality=n, где n может принят значение от 1 до 100 - для определения качества JPEG сжатия. Если параметр отсутствует, то применяется качество сжатия исходного файла. Если исходный файл не сжат, используется значение качества по умолчанию, равное 90.

BitsPerPixel={24,8,1} - число бит на пиксел для преобразования цветных изображений в изображения в градациях серого или изображений в градациях серого в бинарные изображения.


Источник файлов

Источник файлов для применения макроса можно указать с помощью параметра SourceFolder=<Полный путь к файлам>. В этом случае будут обрабатываться все растровые файлы в указанной папке файлы с расширениями <.tif>, <.bmp>, <.raw>, <.dip>. Если источник файлов не указан в макросе, то макрос будет применен ко всем файлам, открытым в программе. Это позволяет обрабатывать файлы, находящиеся в разных папках. Если и в программе нет открытых файлов, выдается сообщение "Нет файлов для обработки".


Интерфейс пользователя

Интерфейс пользователя состоит из 4-х групп элементов и 3-х кнопок.

Группа "Параметры изображения" - справочная. В ней указываются параметры обрабатываемого изображения: ширина и высота - в пикселях, размер ПЗС линейки сканера - в пикселях, количество швов между полосами сканирования и направление сканирования (расположение полос сканирования).

Группа "Параметры коррекции" - отображает и позволяет изменять параметры коррекции изображения.

Для изображения с горизонтальным расположением полос сканирования - область действия и значение изменения яркости выше и ниже выбранного шва между полосами. Для изображения с вертикальным расположением полос сканирования - область действия и значение изменения яркости слева и справа от выбранного шва между полосами. Для цветного изображения эти параметры можно подбирать только для нужных цветовых каналов и для каждого канала индивидуально. Влияние параметра, указанного в поле "Изменить ... на" максимально проявляется возле шва и линейно убывает к границе действия корректировки. Отрицательное значение параметра указывает, что яркость необходимо снижать, положительное - повышать. Для области действия слева/снизу - значения границы отрицательные, для области справа/сверху - положительные.

Группа "Настройки" - для выбора номера шва и цветового канала цветных (RGB) изображений. Для изображений в градациях серого кнопки выбора канала не отображаются. В поле "Перепад на шве" указывается усредненная разность значений яркости справа от шва - слева от шва для вертикального расположения полос и разность сверху от шва - снизу от шва для горизонтального расположения полос. В поле "Край-середина" указывается разность усредненных значений яркости край линейки(район шва) - середина линейки. Значения для этих полей вычисляет программа. Эти значения помогают выбрать значения для полей "Изменить ... на" в группе "Параметры коррекции".

Группа "Включить коррекцию швов" содержит флажки индивидуального включения/отключения коррекции каждого шва и флажок включения/отключения всех швов сразу.

Кнопка "Применить ко всем" - копирование параметров корректировки выбранного шва в параметры остальных швов.

Кнопка 'Ok' - выполнить корректировку изображения. Параметры корректировки швов запоминаются в файл DIPEdit.ini и будут использоваться при формировании скорректированного изображения.

Кнопка "Выход" - корректировку не выполнять, окно закрыть.