Пакет программ "Дельта"

Top Next

Программное обеспечение цифровой фотограмметрической станции "Дельта" - это пакет программ, предназначеный для реализации проектов работ по созданию и обработке цифровых карт. Исходным материалом для создания цифровых карт служат растровые образы, полученные сканированием аэроснимков, космических снимков, планов и карт на бумажных носителях, а также результаты наземной съемки.

Пакет программ включает в себя программы MODELS.EXE, TRIANPR.EXE,TRIADA.EXE и GED.EXE. Когда запускается програма MODELS.EXE, появляется основная панель инструментов. Нажмите на соответствующую кнопку на панели инструментов, чтобы войти в один из основных разделов пакета:

· Раздел формирования файла описания фотокамер (кнопка Cameras), использованых для получения снимков, обрабатываемых в проекте.
· Раздел формирования файла опорных точек для проекта (кнопка Ground).
· Раздел формирования файла общего описания блока снимков (кнопка Blocks).
· Раздел сбора данных для сгущения сети (кнопка Triangulation).
· Раздел внутреннего ориентирования снимков (кнопка Models - далее в появившемся меню пункт Внутреннее ориентирование).
· Раздел взаимного ориентирования стереопары (кнопка Models - далее в появившемся меню пункт Взаимное ориентирование).
· Раздел внешнего ориентирования растрового образа (кнопка Models - далее в появившемся меню пункт Внешнее ориентирование).
· Раздел преобразования снимков в эпиполярную систему координат - далее в появившемся меню пункт В эпиполярную систему.
· Программа создания и обработки цифровых карт (GED.EXE).
· Программа обработки растровых изображений (DIPEdit.exe).
· Раздел обмена элементами ориентирования (кнопка Архив) между файлом цифровой модели Models.ini и снимками, создания архива файлов цифровых моделей.

Для формирования и обновления цифровой карты необходимо с помощью растровых образов и дополнительных данных создать цифровую модель местности.

Для создания цифровой модели необходимо выполнить следующие этапы:

1. Определить данные съемочной камеры (для растрового образа карты или плана этот этап пропускается).
2. Определить опорные точки для ориентирования растрового образа. Особое внимание обратить на порядок координат X и Y. Для ориентирования используются точки в системе Гаусса-Крюгера (ось X на север).
3. Выполнить внутреннее ориентирование растрового образа (образов).
4. Для стереопары выполнить взаимное ориентирование снимков.
5. Выполнить внешнее ориентирование цифровой модели.
6. При необходимости преобразовать снимки в эпиполярную систему координат.

В программах реализован выбор языка интерфейса: английский или русский.
Для программ MODELS.EXE, TRIANPR.EXE,TRIADA.EXE и GED.EXE язык интерфейса устанавливается программой GED.EXE (пункт меню Сервис | Настройки). Программа DIPEdit.exe имеет собственный выбор языка интерфейса.
Выбранный язык вступает в действие только после перезагрузки программы.


Обзор

Описание камер

Previous Top Next

Программа предназначена для создания и редактирования файла, содержащего описания фотокамер. Если растровые образы, по которым необходимо собирать данные, были получены путем сканирования аэро- или космических снимков, то в этом разделе нужно ввести характеристики использованных камер.

Примечание: Если вы используете для сбора данных только сканированные образы карт, планов и т.п, вам не нужно вводить данные в этом разделе. В таком случае просто пропустите этот этап создания цифровой модели.

Каждый пункт списка камер описывает один тип камеры со своими характеристиками. Эти характеристики включают в себя такие общие параметры, как вид проекции, фокусное расстояние, базис фотографирования, информацию о координатных метках, информацию о дисторсии объектива и некоторую дополнительную информацию, если камера - панорамная. Рекомендуем сразу внести в список данные всех камер, снимки с которых будут в дальнейшем использоваться для создания цифровой модели, - далее вам потребуется только выбирать описание нужной камеры и можно будет сразу переходить к следующему этапу.

Щелкнув мышкой на кнопке Camera главной панели инструментов, вы вызываете окно списка камер (Camera list). В нем можно манипулировать списком камер с помощью команд меню или кнопок панели инструментов. Подробнее функциях меню и кнопок см. в разделе "Интерфейс пользователя".

В левой части окна расположен список камер (Camera list). Чтобы пометить камеру в списке, щелкните на ее названии в списке. При этом название камеры помечается синим цветом и в соответствующих полях выводятся характеристики этой камеры.

Если растровые снимки были получены сканированием аэро- или космических снимков, то необходимо указать используемую камеру. Для этого пометьте нужную камеру, а затем выполните команду "Camera|Set as current". Имя текущей камеры будет изображаться жирным шрифтом. Данные текущей камеры будут использованы в процессе ориентирования.

Каталог описания камер формируется в файле MODELS.INI. При открытии каталога с другим именем, описания камер из этого каталога копируются в файл MODELS.INI.


Общие

Общие характеристики камеры

Общие характеристики камеры включают в себя следующую информацию:

· Укажите вид съемки, используемой в камере, выбрав соответствующий пункт из выпадающего списка над списком камер. Возможные виды съемки:

Central(Центральная) Центральная проекция.
Panoramic(Панорамная) Панорамная съемка.
Digital(Цифровая) Цифровая камера

При выборе панорамной съемки на экране активизируется кнопка Panoramic, с помощью которой можно вызвать форму для ввода, просмотра и корректировки дополнительных параметров, присущих только панорамной камере.

· Введите фокусное расстояние камеры (в миллиметрах) в поле ввода Focus.

· Укажите паспортные значения расстояний DX и DY между эталонными метками камеры в соответствующих полях ввода. Эти параметры - обязательные, если нет координат меток. Значения параметров указываются в миллиметрах.

· Введите базис фотографирования (в миллиметрах) в поле ввода Base. Этот параметр необходим только для обработки стереопар снимков. При обработке одиночных снимков параметр не используется (значение может быть произвольным).

Значение базиса определяется при планировании залета. Для использования камеры с различными базисами можно либо корректировать базис камеры, либо создать несколько описаний камеры с нужными базисами.

· Укажите паспортные значения координат X0 и Y0 (в миллиметрах) смещения главной точки снимка в соответствующих полях ввода. При отсутствии данных введите нулевые смещения.

· При необходимости используйте кнопку Distortion для вызова формы ввода, просмотра и корректировки таблицы описания дисторсии объектива камеры.
·


Параметры панорамной камеры

Для панорамной камеры необходимо указать характеристики панорамной камеры:

· Panoramic mode. Параметр задает вид конструкции панорамной камеры. Из выпадающего списка можно выбрать следующие значения:

0 - нет информации о конструкции камеры;
1 - камера с комапенсацией сдвига изображения за счет несоосности расположения оси сканирующих зеркал с оптической осью объектива.

При нулевом значении параметра сдвиг главной точки снимка будет определятся по общим формулам расчета сдвига. При ненулевом значении сдвиг главной точки будет определяться по формулам, учитывающим конструктивные особенности камеры.

· Constant. Указывается значение константы для расчета сдвига главной точки снимка (как правило, константа имеет нулевое значение).

· Eccentricity. Указывается значение эксцентриситета оси объектива к оси вращения зеркал (для камер вида 1). Значение вводится в миллиметрах.

· Orbit height. Указывается средняя высота орбиты носителя (в метрах).

· Exposition time. Указывается время экспонирования кадра (в секундах).


Координатные метки

Характеристики камеры. Координатные метки

В нижней правой части окна отображения описания камеры расположена таблица координат эталонных меток снимка. В этой таблице указываются порядковый номер метки и ее координаты X и Y в системе координат снимка. Таблица позволяет указать координаты до 16 меток. Вносить изменения в таблицу можно только в режиме редактирования описания камеры. Для изменения списка координатных меток используйте следующие кнопки:

· Щелкните на кнопке "Use DX DY" чтобы сформировать координаты опорных точек на основании значений параметров DX и DY.

· Щелкните на кнопке "Add" чтобы добавить описание новой координатной метки в конец таблицы описаний координатных меток. Номер новой метки на 1 больше номера последней метки в таблице, а координаты метки - нулевые. Необходимо войти в режим редактирования координат новой метки и указать правильные координаты.

· Щелкните на кнопке "Insert" чтобы вставить описание новой координатной метки перед описанием метки таблицы, на которой находится курсор. Необходимо войти в режим редактирования координат новой метки и указать правильные координаты.

· Щелкните на кнопке "Delete" чтобы удалить описание той координатной метки, на которой находится курсор.
·


Дисторсия объектива

Для ввода, просмотра и корректировки описания дисторсии объектива вызывается форма, в которой вдоль горизонтальных, вертикальных и диагональных линий отображаются зоны объектива и введенные значения дисторсии, Для ввода или корректировки значений дисторсии необходимо нажать кнопку на окончании линии выбранного направления, После нажатия кнопки появляется таблица, в верхней строке которой необходимо указать зоны объектива, а в нижней строке - значения дисторсии в каждой зоне. При нажатии кнопки Ok(Да) введенные значения записываются в описание камеры, При нажатии кнопки Cancel(Отменить) - данные ввода игнорируются.
Есть возможность интерполировать значения дисторсии для направлений, дисторсия для которых неизвестна (кнопка Fill Absent(Дополнить)). Если известна дисторсия на двух соседних напрвлениях, то дисторсия вычисляется как среднее соседних. Если известны значения дисторсии на одном направлении, то для остальных направлений (против часовой стрелки) значения дисторсии повторяются.


Обзор

Описание камер. Интерфейс пользователя

Главное меню описания камер содержит следующие разделы:

· Меню "File(Файл)" содержит команды:

Add from...(Добавить из...)
Save As...(Сохранить как...)
Print(Печать)
Exit(Выход)
· Меню "Camera(Камера)" содержит команды:

Set as current(Сделать активной)
Edit(Правка)
Copy(Копировать)
Insert(Вставить)
Add(Добавить)
Create rotated(Создать развернутую)
Delete(Удалить)

· Щелчок мышью на разделе "Help" вызывает помощь.

Примечание: Чтобы получить помощь по какой-либо команде меню, выберите этот пункт меню, но не выполняйте команду. Вместо щелчка мышью на этом пункте или нажатия Enter нажмите F1. Помощь по этой команде появится на экране.

Под главным меню расположена панель инструментов, кнопки которой дублируют команды основного меню. Вместо выполнения команды меню можно щелкнуть мышью на соответствующей кнопке.


Меню «File»

Описание камер. Меню «File»

Команда "File(Файл) | Add from...(Добавить из...)"
После активизации команды вызывается стандартный диалог Windows, позволяющий выбрать файл с описаниями камер. Если указать имя несуществующего файла, откроется пустой файл с таким именем. Если имя файла не совпадает с именем MODELS.INI, открывается окно со списком камер в файле. Все помеченные описания камер и отсутствующие в MODELS.INI, копируются в файл текущей модели.

Команда "File(Файл) | Save As...(Сохранить как...)"
Команда предназначена для создания резервной копии файла описания камер.
После активизации команды вызывается стандартный диалог Windows, позволяющий
указать файл для копии. Если указано имя существующего файла, выдается запрос на подтверждение перезаписи файла.

Команда "File(Файл) | Print(Печать)"
Команда выводит на принтер описания всех камер.

Команда "File(Файл) | Exit(Выход)"
При активизации этой команды программа закрывает файл описания камер и завершает свою работу.


Меню «Camera»

Описание камер. Меню «Camera»

Команда "Camera | Set as current(Камера | Сделать активной)"
Команда позволяет указать олисание камеры, используемой для создания цифровой модели.
Для этого необходимо в списке камер щелчком левой клавиши мышки указать нужную камеру и выполнить эту команду. Имя текущей камеры отобразится жирным шрифтом.

Команда "Camera | Edit(Камера | Правка)"
Команда предназначена для активизации режима редактирования описания указанной камеры.
Изменение характеристик камеры возможно только в этом режиме. Повторная активизация команды завершает режим редактирования. При этом отредактированное описание камеры записывается в файл.

Подобным образом можно также включать/выключать режим редактирования щелкая мышью на кнопке Edit на панели инструментов. Эта кнопка показывает состояние режима редактирования: если она находится в нажатом состоянии - редактирование камеры включено, иначе - выключено.

Примечание: В режиме редактирования остальные команды главного меню деактивированы.

Команда "Camera | Copy(Камера | Копироватьть)"
Выполнение команды позволяет запомнить описание помеченной камеры. Это описание можно вставить или добавить в список с помощью команд "Вставить" или "Добавить".

Команда "Camera | Add(Камера | Вставить)"
Выполнение команды позволяет добавить в список перед помеченной камерой новое описание камеры. После активизации команды вставляется описание камеры, сохраненное по команде "Копировать" или описание с параметрами по умолчанию и программа переходит в режим редактирования этого описания.

Команда "Camera | Add(Камера | Добавить)"
Выполнение команды позволяет добавить в конец списка новое описание камеры. После активизации команды добавляется описание камеры, сохраненное по команде "Копировать" или описание с параметрами по умолчанию и программа переходит в режим редактирования этого описания.

Команда "Camera | Create rotated(Камера | Создать развернутую)"
Выполнение команды позволяет вставить после помеченной камеры описание новой камеры, параметры которой (сдвиг центральной точки, координаты меток и дисторсия) повернуты на 180 градусов относительно помеченной камеры. Это позволяет легко создавать камеры для обработки маршрутов противоположных направлений (если такие есть в блоке).

Команда "Camera | Delete(Камера | Удалить)"
Выполнение этой команды приводит к удалению из файла описания помеченной камеры.


Обзор

Список опорных точек

Этот раздел предназначен для создания и управления списком опорных точек. Можно создать список опорных точек сразу для целого блока образов. Затем следует выбрать те точки, которые будут использованы для ориентирования конкретного снимка или стереопары.

Чтобы войти в раздел опорных точек, щелкните мышью на кнопке Ground(Опора) на главной панели инструментов программы. Появится окно Ground control points(Работа с опорными точками), которое содержит несколько групп элементов управления, описанных ниже.

В правой части окна расположены две таблицы с идентификаторами и координатами опорных точек, между которыми расположены несколько кнопок для управления таблицами. Эти кнопки позволяют добавлять точки в таблицы, удалять, модифицировать их и т.п. В верхней таблице отображаются опорные точки для текущей модели. Они загружаются из файла текущей модели Models.ini и всегда сохраняются в этот файл при выходе из программы формирования опорных точек.

В нижнюю таблицу можно загрузить опорные точки из текстового файла, выбрав соответствующий файлу формат данных в списке форматов. Обе таблицы имеют одинаковые возможности по вводу и корректировке данных, а также могут обмениваться точками. Кнопки управления (удалить, добавить, вставить, редактировать, обменять X и Y) действуют только на активную таблицу. Курсор пометки ячеек в активной таблице имеет синий цвет, в пассивной - серый.

В левой части окна расположена графическая схема расположения опорных точек. Вы можете выполнять некоторые операции, как например, пометка точек, непосредственно на схеме. В графической схеме отображаются точки активной таблицы.

В верхней части окна расположено основное меню, которое содержит команды работы с отдельными точками и с файлами опорных точек. Некоторые из этих команд дублируются командами контекстного меню. Некоторые команды имеют также соответствующие им кнопки на панели инструментов, которая расположена под основным меню.


Схема расположения

Схема расположения опорных точек

В левой части окна расположена графическая схема расположения опорных точек. Схема позволяет увидеть взаимное расположение точек списка, облегчает пометку точек и другие операции. Схема формируется для активной таблицы опорных точек.

Каждая опорная точка изображается на схеме со своим идентификатором. Если точек в списке очень много, то схема может быть загромождена идентификаторами точек, налагающимися друг на друга. в этом случае можно отключить изображение на схеме идентификаторов как для всех точек (команда "View|ID Visible"), так и только для помеченных (команда "View|ID Selected Only").

Вы можете увеличивать/уменьшать изображение схемы, чтобы рассмотреть, как расположены точки в той или иной области.

Чтобы пометить точку непосредственно на схеме, щелкните на ее изображении на схеме или рядом с ним. Точка пометится и изменит свой цвет на красный (по умолчанию). Если щелкнуть на помеченной точке, то пометка с нее снимается (точка меняет цвет на черный - по умолчанию). Можно также помечать или снимать пометку со всех точек одновременно с помощью команд "Edit|Select All" и "Edit|Deselect All" соответственно.

Можно вызывать некоторые из указанных команд с помощью контекстного меню, которое появляется, если щелкнуть правой кнопкой мыши на схеме.


Создание списка точек

В правой части окна расположены две таблицы с идентификаторами и координатами опорных точек.

В верхней таблице отображаются опорные точки для текущей модели. Они загружаются из файла текущей модели Models.ini и всегда сохраняются в этот файл при выходе из программы формирования опорных точек.

В нижнюю таблицу можно загрузить опорные точки из текстового файла, выбрав соответствующий файлу формат данных в списке форматов файлов. Обе таблицы имеют одинаковые возможности по вводу и корректировке данных, а также могут обмениваться точками.

Кнопки управления (удалить, добавить, вставить, редактировать, обменять X и Y), расположеные между таблицами, действуют только на активную таблицу. Курсор пометки ячеек в активной таблице имеет синий цвет, в пассивной - серый. Для активизации нужной таблицы необходимо щелкнуть на ней левой клавишей мышки.

Каждая запись в списке опорных точек представляется строкой в таблице. Крайняя левая ячейка в строке содержит идентификатор точки (ID), за которым следуют координаты X,Y и Z в соответствующих ячейках.

Результат операций над точками таблицы зависит от того, на какой строке таблицы находится фокус. Активная строка - это строка, на которой находится фокус (прямоугольник фокуса отображается цветом)). Когда производится операция над точкой (щелчок на кнопках "Add", "Delete", "Insert", "Edit"), это затрагивает целую строку в таблице.

Можно создать файл со списком опорных точек в любом текстовом редакторе. Файл опорных точек должен быть простым текстовым файлом (без установок шрифтов, форматирования и т.п). Каждая строка в таком файле должна содержать идентификатор точки, а за ним в этой же строке должны следовать координаты этой точки. Значения идентификатора и координат должны быть разделены одним или несколькими символами ПРОБЕЛ.

Список опорных точек можно создать непосредственно в одной из таблиц. Для этого необходимо активизировать эту таблицу, очистить ее (если это необходимо), нажав кнопку "Clear", и сформировать новый список опорных точек с помощью кнопок "Add" и "Insert". При обнаружении ошибки перевести фокус на строку с ошибкой и использовать кнопку "Edit" для редактирования опорной точки.


Добавление/удаление точек

Щелкните на кнопке "Add(Добавить)" чтобы добавить описание новой опорной точки в конец таблицы описаний опорных точек.

Щелкните на кнопке "Insert(Вставить)" чтобы вставить описание новой опорной точки перед точкой, на которой находится фокус.

Щелкните на кнопке "Edit(Ghfdrf)" чтобы редактировать описание опорной точки, на которой находится фокус.

Для ввода нового описания опорной точки выводится окно редактирования, в котором необходимо указать идентификатор опорной точки и координаты X, Y и Z в системе координат X на север.

При вводе описания опорной точки необходимо учесть следующее:
· Идентификатор точки может содержать не более 29 символов.
· Идентификаторы не должны повторяться в пределах одного и того же файла.
· Координаты опорных точек (графы X,Y и Z) указываются в метрах с необходимым количеством десятичных знаков. Координаты X и Y опорных точек указываются в системе Гаусса - Крюгера. При чтении опорных точек из файла необходимо правильно указать формат преобразования координат или воспользоваться кнопкой "X<--->Y" (обменять координаты Y и X).
· Разделитель между целой и дробной частями указывается соответствующий региональным установкам Windows.

Щелкните на кнопке "Delete(Удалить)" чтобы удалить описание той опорной точки, на которой находится фокус.

Для очистки всей таблицы необходимо нажать кнопку "Clear(Очистить)".

Кнопка "X<--->Y" действует на все точки активной таблицы.


Выбор точек для ориентирования

Выбор опорных точек для ориентирования

В файл цифровой модели переносятся все точки из верхней таблицы описания опорных точек. Описания опорных точек можно сформировать непосредственно в этой таблице или перенести из нижней таблицы. Для переноса точек из нижней таблицы необходимо:

1. Открыть существующий файл опорных точек или создать список опорных точек в нижней таблице, как описано в разделе "Создание списка опорных точек".

2. Пометить в нижней таблице точки, которые будут использованы для процедуры ориентирования конкретного образа (образов). Чтобы пометить точку в таблице, удерживая клавишу Ctrl щелкните на любой ячейке в строке с данными нужной точки. Можно также помечать точки непосредственно на схеме.
3. Нажать кнопку arrowup (стрелка вверх) для переноса помеченных точек нижней таблицы в верхнюю.

Убедитесь, что координаты X опорных точек направлены на север, а координаты Y - на восток (система координат Гаусса-Крюгера). Если для приведения координат к этой системе необходимо поменять их местами, активизируйте верхнюю таблицу и щелкните на кнопке "X<--->Y".

В файл цифровой модели точки из верхней таблицы автоматически переносятся при закрытии формы для работы с опорными точками.

Для создания копии точек верхней таблицы необходимо:

1. Очистить нижнюю таблицу.

2. Пометить точки верхней таблицы.

3. Нажать кнопку arrdown (стрелка вниз) для переноса помеченных точек верхней таблицы в нижнюю.

4. Выполнить команду File | Save As...


Обзор разделов меню

Список опорных точек. Обзор разделов меню

Меню окна опорных точек содержит несколько разделов, описанных ниже.

File(Файл) Содержит команды для операций с файлами опорных точек.
Edit(Правка) Cодержит команды для редактирования списка опорных точек.
View(Вид) Cодержит команды для изменения режима просмотра схемы опорных точек.
Settings(Настройки) Cодержит команды для изменения атрибутов опорных точек при изображении их на схеме.
Help(Помощь) Вызов контекстной справки для описания опорных точек

Можно также пользоваться контекстным меню для выполнения некоторых команд основного меню. Щелкните правой кнопкой мыши на схеме, чтобы вызвать контекстное меню. Оно содержит команды:

Select All(Пометить все) Равносильна команде "Edit|Select All".
Deselect All(Снять пометку) Равносильна команде "Edit|Deselect All".
Define Photo(Контур снимка) Равносильна команде "Edit | Define Photo".
Hide Photo(Спрятать контур) Равносильна команде "Edit | Hide Photo".
ID Visible(ID видимый) Равносильна команде "View|ID Visible".
ID Selected Only(ID только помеченных) Равносильна команде "View|ID Selected Only".
Cancel(Отменить) Убирает контекстное меню с экрана.


Раздел "File"

Список опорных точек. Меню "File"

Команда "File|New(Файл|Новый)"
Эта команда создает новый файл опорных точек.

Команда "File|Open...(Файл|Открыть...)"
Команда загрузки списка опопрных точек из файла выводит на экран стандартное диалоговое окно Windows для выбора файлов, которое позволяет выбрать файл с описаниями опорных точек. После выбора файла список содержащихся в нем точек появится в нижней таблице и на схеме опорных точек.

Команда "File|Close(Файл|Закрыть)"
Эта команда закрывает открытый файл опорных точек. Если список опорных точек был изменен со времени последней записи на диск, то появится окно с предложением записать список в файл.

Команда "File|Save(Файл|Сохранить)"
Эта команда записывает список опорных точек в тот же файл, откуда он был загружен.

Команда "File|Save As...(Файл|Сохранить как...)"
Команда загрузки списка опопрных точек из файла выводит на экран стандартное диалоговое окно Windows для выбора файлов, которое позволяет указать имя файла, куда нужно сохранить описания опорных точек. С помощью этой команды можно создавать резервные копии одного и того же списка точек под разными именами.

Команда "File|Get Current(Файл|Прочитать текущую)"
Эта команда загружает в верхнюю таблицу опорные точки из файла цифровой модели. Это позволяет просмотреть, какие именно точки будут использованы для ориентирования, и при необходимости изменить эти точки на другие. Эту команду можно также вызвать из контекстного меню.

Команда "File|Exit(Файл|Выход)"
Эта команда закрывает окно опорных точек.


Раздел "Edit"

Список опорных точек. Меню "Edit"

Команда "Edit | Add(Правка | Добавить)"
Команда применяется для добавления новой опорной точки в конец таблицы. Для ввода параметров опорной точки выводится окно редактирования. Необходимо указать правильные значения идентификатора и координат новой точки через ПРОБЕЛ.

Команда "Edit | Insert(Правка | Вставить)"
Команда применяется для вставки новой опорной точки в любую позицию в таблице. Новая точка вставляется перед активной строкой таблицы. Для ввода параметров опорной точки выводится окно редактирования. Необходимо указать правильные значения идентификатора и координат новой точки.

Команда "Edit | Edit(Правка | Правка)"
Команда применяется для редактирования активной опорной точки таблицы. Для редактирования параметров опорной точки выводится окно, содержащее редактируемые значения. Необходимо указать правильные значения идентификатора и координат новой точки.

Команда "Edit | Delete(Правка | Удалить)"
Команда применяется для удаления активной опорной точки.

Команда "Edit | Select All(Правка | Пометить все)"
Команда применяется для пометки всех опорных точек. Ее также можно вызвать из контекстного меню.

Команда "Edit | Deselect All(Правка | Снять пометку)"
Команда применяется для снятия пометки со всех опорных точек. Ее также можно вызвать из контекстного меню.

Команда "Edit | Define Photo(Правка | Контур снимка)"
Команда применяется для пометки опорных точек конкретного снимка. При помощи этой команды на схеме опорных точек можно отобразить прямоугольник, окаймляющий необходимые опорные точки. При активизации команды курсор отображается в виде перекрестия. Укажите положение одного из углов прямоугольника относительно опорной точки, ближайшей к этому углу на снимке. Удерживая нажатой левую клавишу мыши растягивайте прямоугольник до нужной величины. При удержании нажатой клавиши Ctrl можно вращать прямоугольник вокруг начальной точки. Завершив формирование прямоугольника отпустите левую клавишу мыши. Все точки, попавшие внутрь прямоугольника будут помечены. Эту команду также можно вызвать из контекстного меню.

Команда "Edit | Hide Photo(Правка | Спрятать контур)"
Команда применяется для удаления контура снимка со схемы расположения опорных точек. Ее также можно вызвать из контекстного меню.


Раздел "View"

Список опорных точек. Меню "View"

Команда "View|Zoom In"
Эта команда увеличивает изображение схемы расположения точек.

Команда "View|Zoom Out"
Эта команда уменьшает изображение схемы расположения точек.

Команда "View|Show All"
Эта команда изменяет увеличение схемы опорных точек так, чтобы были видны все точки одновременно.

Команда "View|ID Visible"
Используйте эту команду, чтобы включать/выключать режим изображения идентификаторов на схеме расположения опорных точек. Если режим включен (соответствующий пункт в меню отмечен "галочкой"), то идентификаторы опорных точек изображаются на схеме, иначе изображаются только точки. Для вызова этой команды можно использовать контекстное меню.

Команда "View|Selected only"
Используйте эту команду, чтобы включать/выключать режим изображения идентификаторов помеченных точек на схеме расположения опорных точек. Если режим включен (соответствующий пункт в меню отмечен "галочкой"), то только идентификаторы помеченных опорных точек изображаются на схеме. Для вызова этой команды также можно использовать контекстное меню.


Раздел "Settings"

Список опорных точек. Меню "Settings"

Команда "Settings|Point Color..."
Эта команда вызывает стандартное диалоговое окно Windows для выбора цвета. Используйте это окно, чтобы выбрать цвет непомеченных точек на схеме расположения точек.

Команда "Settings|Selected Color..."
Эта команда вызывает стандартное диалоговое окно Windows для выбора цвета. Используйте это окно, чтобы выбрать цвет помеченных точек на схеме расположения точек.

Команда "Settings|Background Color..."
Эта команда вызывает стандартное диалоговое окно Windows для выбора цвета. Используйте это окно, чтобы выбрать цвет фона для схемы расположения точек.

Команда "Settings|Font..."
Эта команда вызывает стандартное диалоговое окно Windows для выбора шрифта. Используйте это окно, чтобы выбрать шрифт, которым будут выводиться идентификаторы на схему расположения точек.


Создание цифровой модели. Общие положения

Создание цифровой модели

Цифровая модель местности создается на основе растрового образа и дополнительной информации. Эта информация указывается в файле в описании аэрофотокамеры и опорных точек.

Вся информация для формируемой цифровой модели и результаты ее формирования собираются в файле MODELS.INI, который должен находится в директории с программами создания цифровой модели.

Текстовые отчеты о результатах ориентирований записываются в файл MODELS.LOG, формируемый в директории с программами создания цифровой модели. Результаты ориентирований дописываются в конец файла и со временем он может увеличиться до больших размеров. Если файл отсутствует, программы ориентирования создают его сами.

Для создания цифровой модели необходимо:

1) Выбрать описание аэрофотокамеры (кроме модели, создаваемой по сканированой карте).
2) Пометить опорные точки, необходимые для внешнего ориентирования модели и перенести их в файл описания модели.
3) Выполнить внутреннее ориентирование растрового образа (кроме модели, создаваемой по сканированой карте).
4) Выполнить взаимное ориентирование снимков (только при обработке стереопары).
5) Выполнить внешнее ориентирование цифровой модели.
6) При необходжимости преобразовать модель в эпиполярную систему координат.


Обзор

Ориентирование растровых образов. Интерфейс пользователя

Все разделы ориентирования в пакете программ "Дельта" имеют общие свойства для перемещения образов, установки контрастности, яркости и гамма-коррекции и изменения увеличения. На каждой стадии ориентирования вы можете управлять снимком/снимками подобным способом. Основные принципы работы с растровыми образами описаны ниже.

На экране находится один или два образа, в зависимости от режима (single photo - одиночный снимок или stereopair - стереопара). Каждая панель для растрового образа может выводить на экран сравнительно небольшую часть образа, однако область видимости можно перемещать с помощью мыши или штурвалов. Такое перемещение возможно только при включенном режиме управления.

Регистрация точек возможна только в режиме управления. В этом режиме в центре каждой панели образов изображается марка, которая указывает текущую позицию для регистрации.

Гамма-коррекцию образов и изменение увеличения можно производить независимо от того, включен режим управления или нет. Если у мыши есть колесо прокрутки, то масштаб изображения можно изменять вращением колеса при нажатой клавише <Ctrl>.


Режим управления

Режим управления при ориентировании образов

При ориентировании перемещение видимой области образа/образов только при включенном режиме управления.

Отключить управление растровым образом можно только с помощью нажатия клавиши Esc на клавиатуре. Войти в режим управления можно, щелкнув мышью на кнопке управления Capture(Захват).

В режиме управления в центре панели, содержащей растровый образ, изображается марка (зеленый крест - по умолчанию). Для панелей стереопары марка изображается в центре каждой панели.

В режиме управления видимая область перемещается движением мыши или вращением штурвалов. Для стереопары оба образа движутся синхронно. При нажатой на клавиатуре клавише Ctrl или правой двойной педали перемещается только правый образ. Изменение высоты в программе внешнего ориентирования модели осуществляется с помощью мышки при нажатой клавише Ctrl, вращением ножного штурвала или колесом прокрутки мыши(если такое у мыши есть).

По умолчанию марка имеет форму зеленого креста. В режиме управления можно выбрать из одну из нескольких типов марок. Чтобы изменить тип марки нужно, удерживая нажатой клавишу Shift, нажимать клавиши ¬(стрелка влево) или ®(стрелка вправо). Если нажатие одной из этих комбинаций клавиш уже не изменяет формы марки, значит достигнут последний возможный вид марки - нажимайте другую комбинацию клавиш, чтобы просмотреть формы марок в обратном порядке.

Аналогично изменяется и цвет марки. Удерживая клавишу Shift, нажимайте на клавиши (стрелка вверх) или Ї(стрелка вниз), чтобы выбрать один из нескольких предлагаемых программой цветов.

palette Чтобы назначить марке любой цвет, щелкните на кнопке "палитра" на панели инструментов. Появится стандартное диалоговое окно Windows для выбора цвета, где вы можете выбрать любой цвет доступный в вашей системе.


Коррекция образов

Над растровыми образами можно выполнять различные операции коррекции:

1) Гамма-коррекция. Выполнить гамма-коррекцию растрового образа можно с помощью нажатия клавиш Page Up и Page Down. Когда режим управления выключен, можно выполнить гамма-коррекцию изменением положения ползунка G(Г) на панели инструментов.

2) Коррекция контрастности. Чтобы изменить контрастность образа/образов сначала следует выключить режим управления. Когда режим управления выключен, можно выполнить коррекцию контрастности изменением положения ползунка C(К) на панели инструментов.

3) Коррекция яркости. Чтобы изменить яркость образа/образов сначала следует выключить режим управления. Когда режим управления выключен, можно выполнить коррекцию яркости изменением положения ползунка B(Я) на панели инструментов.

При проведении коррекции для стереопары оба растровых образа изменяются одновременно. Чтобы произвести коррекцию только левого образа, удерживайте клавишу Ctrl и нажимайте клавишу или передвигайте соответствующий ползунок на панели инструментов. Чтобы изменить только правый образ, удерживайте клавишу Alt и нажимайте клавишу или передвигайте ползунок.

Кроме этих операций существует еще одно преобразование снимка, которое влияет на передачу цветов и оттенков - переключение режима позитив/негатив образа. Когда вы нажимаете клавишу "*"(звездочка), растровый образ/образы переходят в негативный, инверсный режим по отношению к исходному образу/образам. То есть, для черно-белых изображений темные участки становятся светлыми, а светлые - темными, а для цветных каждая точка изображения выводится в цвете дополняющем цвет исходной точки до белого. Если нажать клавишу "*" в негативном режиме, то изображение вернется в исходное состояние (в позитивный режим).


Масштабирование

Изменить масштаб отображения растрового образа можно с помощью нажатия клавиши "+" (ллюс - увеличить масштаб) и клавиши "-" (минус - уменьшить масштаб). Увеличение/уменьшение доступно всегда - независимо от того, включен режим управления или нет. Если у мыши есть колесо прокрутки, то масштаб изображения можно изменять вращением колеса при нажатой клавише <Ctrl>.

Чтобы масштабирование выполнялось быстро, рекомендуется в используемых растровых файлах создавать так называемую пирамиду (последовательность уменьшенных образов исходного образа, которая хранится в том же файле, что и исходный образ). Создание пирамиды максимально возможного размера увеличивает размер растрового файла на 33 процента.

Существует режим навигации - при одновременном нажатии клавиш Ctrl и Alt или левой двойной педали масштаб устанавливается 1:8 к предыдущему масштабу. При отпускании клавиш или педали масштаб возвращается к исходному.


Регистрация координат

Регистрацию координат наблюдаемой точки на каждом этапе ориентирования можно выполнить несколькими способами:

1) щелкнуть левой кнопкой мыши;
2) нажать и отпустить одиночную педаль;
3) нажать клавишу Пробел на клавиатуре;
4) нажать клавишу Enter на клавиатуре.

Регистрация координат возможна только при включенном управлении.


Обзор

Внутреннее ориентирование

Раздел внутреннего ориентирования растрового образа/образов предназначен для определения параметров преобразования реальной системы координат растрового образа в эталонную систему координат снимка. Для определения этих параметров используются координаты меток из описания фотокамеры и координаты этих же меток измеренные на образе.

Чтобы войти в раздел внутреннего ориентирования нужно нажать на кнопку Model(Модель) на основной панели инструментов программы, а затем выбрать в появившемся меню пункт Inner orientation. После этого на экране появится окно начальных установок, в котором можно указать, какие образы и как требуется ориентировать.

Затем появляется окно Inner orientation(Внутреннее ориентирование), где и производится собственно процесс ориентирования с регистрацией координатных меток.

Результаты внутреннего ориентирования записываются в файл цифровой модели.

Реализовано автоматическое внутреннее ориентирование снимков, если сформирован файл растровых образов меток. Этот файл формируется в процессе "ручного" ориентирования снимка и записывается в директорий, где находится программа внутреннего ориентирования. Все последующие ориентирования снимков программа пытается выполнить автоматически. Если попытка успешная, программа отображает результаты ориентирования, в противоположном случае включается режим активного управления и ориентирование можно выполнить в "ручном режиме".


Начальные установки

Начальные установки для внутреннего ориентирования

Окно начальных установок (Параметры внутреннего ориентирования) позволяет указать следующие параметры для ориентирования:

· Сначала следует указать, будет ли ориентироваться стереомодель (Стереопара) или одиночный образ (Одиночный снимок) в группе Метод ориентирования.

· open Укажите имя одного или двух файлов растровых образов. Для указания имен файлов существуют два поля ввода для левого и правого снимков стереопары (Левый снимок, Правый снимок) с соответствующими кнопками справа от них. При ориентировании одиночного образа его имя указывается в поле ввода Левый снимок. Для выбора имени файла/файлов можно либо ввести его имя в нужном поле ввода, либо щелкнуть на соответствующей кнопку с изображением папки. В последнем случае появится стандартное диалоговое окно Windows для указания имени файла. После выбора файла с помощью этого окна его имя отобразится в поле ввода.

· Убедитесь, что для ориентирования выбрано правильное описание камеры. Имя текущей камеры, выбранной для создания цифровой модели, указано в выпадающем списке Камера. В этом списке можно выбрать другое описание камеры, если это необходимо.

· Укажите, надо ли начинать процесс ориентирования сначала (Начать ориентирование) или следует продолжить последний проведенный процесс (Продолжить) в группе Стадия.

· Укажите, надо ли выполнить процесс ориентирования в автоматическом режиме (Автоматически). Если флажок будет установлен, программа попытается выполнить внутреннее ориентирование по методу корреляции. При успешном завершении ориентирования будут показаны его результаты, в противном случае программа перейдет в режим "ручного" ориентирования.

· Когда все описанные выше настройки произведены, можно приступать собственно к процессу ориентирования, нажав на кнопку Выполнить. Если вы не хотите начинать ориентирование, нажмите на кнопку Отменить.
·


Процесс ориентирования

Процесс внутреннего ориентирования

При переходе из окна начальных настроек к процессу ориентирования появляется окно Внутреннее ориенирование, которое содержит одну или две панели с растровыми образами в зависимости от выбранного метода ориентирования. В этом окне нужно зарегистрировать положения координатных меток образа/образов.

Если вы начинаете ориентирование сначала (см. "Начальные установки"), то при появлении окна внутреннего ориентирования программа включает режим управления и перемещает марку/марки в зону первой координатной метки. Теперь марку/марки нужно переместить точно на координатную метку и зарегистрировать это положение.

При ориентировании стереопары порядок регистрации каждой координатной метки следующий. Сначала нужно установить марку на метку на левом образе, а потом, зафиксировав левый образ (нажмите правую двойную педаль или удерживайте нажатой клавишу Ctrl), установить марку на метку правого образа. Далее зарегистрируйте это положение.

После регистрации положения первой координатной метки программа переместит марку в область следующей метки. Порядок регистрации этой и последующих меток такой же, как для первой метки. При регистрации очередной метки, ее результаты заносятся в таблицу результатов ориентирования. Когда позиция последней координатной метки зарегистрирована, программа выключает режим управления и таблица содержит окончательные результаты ориентирования.

В процессе ориентирования можно временно выключить режим управления, чтобы произвести коррекцию образа/образов. Чтобы продолжить ориентирование, щелкните на кнопке Дальше, ориентирование продолжится со следующей незарегистрированной точки.

Если в окне начальных установок вы выбрали продолжение последнего процесса ориентирования, то программа не включает режим управления. Марка/марки переводится в ту позицию, запись которой в таблице помечена синим цветом.

Если режим управления отключен, то можно пометить строку в таблице результатов (щелчком мыши или клавишами-стрелками). При этом марка/марки перемещаются в позицию, соответствующую этой записи. Теперь можно повторить наблюдение этой точки, нажав на кнопку Повторно. Программа включит режим управления и вы сможете сместить марку с ранее зарегистрированной позиции в другое место.


Таблица результатов

Таблица результатов внутреннего управления

В процессе измерения координат меток формируется таблица результатов, в которой отображаются порядковые номера меток, отклонения измеренных координат от указанных в описании камеры (в микрометрах) и масштабные коэффициенты по осям координат. Пометка любой строки с координатами метки (щелчком мыши или перемещением пометки клавишами-стрелками) при отключенном управлении приводит к перемещению марки на соответствующую метку.

Причины больших отклонений измеренных координат меток от указанных в описании камеры или масштабных коэффициентов, отличающихся от единицы больше, чем на 0.01, могут быть следующие:

1) описание выбранной камеры не соответствует растровому образу;
2) есть ошибки в координатах меток, указанных в описании камеры;
3) низкое разрешение растрового образа;
4) большая деформация растрового образа;
5) низкая точность наведения марки на координатные метки образа.

Кроме таблицы результатов формируется отчет о результатах внутреннего ориентирования, который можно просмотреть, щелкнув на закладке Отчет. Этот отчет можно сохранить в файле, распечатать или скопировать в буфер обмена. Кроме того, отчет всегда сохраняется в файле Models.log.


Обзор

Взаимное ориентирование

Раздел взаимного ориентирования стереопары снимков предназначен для вычисления элементов взаимного ориентирования снимков. Программа использует измеренные по растровым образам координаты характерных точек левого и правого снимков. Программа позволяет использовать различные схемы измерений координат точек: стандартную схему из 6-ти точек, расширенную схему из 12-ти точек и произвольную схему, составленную пользователем.

Чтобы войти в раздел взаимного ориентирования нужно нажать на кнопку Moдель на основной панели инструментов программы, а затем выбрать в появившемся меню пункт Взаимное ориентирование. После этого на экране появится окно начальных установок, в котором можно указать, какие образы и как требуется ориентировать.

Затем появляется окно Взаимное ориентирование, где и производится собственно процесс ориентирования с регистрацией точек.

Результаты взаимного ориентирования записываются в файл цифровой модели.


Начальные установки

Начальные установки для взаимного ориентирования

Окно начальных установок позволяет указать следующие параметры для ориентирования:

· open Укажите имена двух файлов растровых образов. Для указания имен файлов существуют два поля ввода для левого и правого снимков стереопары (Левый снимок и Правый снимок) с соответствующими кнопками справа от них. Для выбора имени файла/файлов можно либо ввести его имя в нужном поле ввода, либо нажать на соответствующую кнопку с изображением папки. В последнем случае появится стандартное диалоговое окно Windows для указания имени файла. После выбора файла с помощью этого окна его имя отобразится в поле ввода.

· Укажите схему расположения точек. Схема обозначает зоны, в которые программа последовательно будет перемещать марки для регистрации очередной точки. Можно выбрать одну из стандартных схем (из 6 или 12 точек) или создать свою собственную схему.

· Укажите, надо ли начинать процесс ориентирования сначала (Начать ориентирование) или следует продолжить последний проведенный процесс (Продолжить) в группе Стадия.

· Процесс взаимного ориентирования можно выполнить в автоматическом режиме, используя корреляцию растровых образов снимков. Для этого необходимо указать общее число точек в каждой зоне снимка и число точек, оставленных в каждой зоне после отсеивания точек с большими параллаксами. Рекомендуемые значения 9 и 3 точки соответственно. Максимальное общее число точек в одной зоне - 49, минимальное - 5. Взаимное ориентирование автоматически выполняется только в режиме "Начать ориентирование" при включенном флаге "Автоматически". После завершения ориентирования и отображения его результатов становятся доступными возможности корректировки результатов (исключение точек, перенаведение и регистрация новых точек).

· Включение флажка Преобразовать в эпиполярную систему приведет к преобразованию снимков в эпиполярную систему координат после завершения процесса взаимного ориентирования. Это необходимо, если углы взаимного ориентирования снимков настолько большие, что искажают стереоэффект. Если хоть один из углов взаимного ориентирования снимков больше 5-ти градусов, программа после завершения ориентирования выдает запрос о преобразовании в эпиполярную систему координат даже при выключенном флажке. При преобразовании снимков в эпиполярную систему координат можно выбрать следующие методы формирования пикселей эпиполярного изображения:
- перенос. Новый пиксел получается простым переносом соответствующего пиксела исходного преобразования;
- билинейное усреднение. Новый пиксел получается усреднением 4-х ближайших пикселей исходного изображения;
- гауссиан 3х3. Новый пиксел получается посредством преобразования матрицы 3х3 исходных пикселей через коэффициенты распределения Гаусса;
- гауссиан 5х5. Новый пиксел получается посредством преобразования матрицы 5х5 исходных пикселей через коэффициенты распределения Гаусса.
Метод переноса самый быстрый, но при его применении на прямолинейных контурах могут образовываться неровности. Методы 2-4 позволяют сглаживать эти неровности. Методы расположены по возрастанию времени преобразования. Для большинства случаев оптимальным является метод билинейного усреднения.

· После выполнения взаимного ориентирования снимков можно создать свободную модель указанного масштаба. Для этого необходимо включить флажок Создать стереомодель и указать масштаб модели. Элементы ориентирования модели создаются после взаимного ориентирования снимков на основании указанного базиса в описании камеры и указанного масштаба.

· Когда все описанные выше настройки произведены, можно приступать собственно к процессу ориентирования, нажав на кнопку Выполнить. Если вы не хотите начинать ориентирование, нажмите на кнопку Отменить.


Схема расположения точек

Схема расположения точек определяет зоны, в которые программа последовательно будет перемещать марки для регистрации очередной точки.

Выбрать схему расположения точек можно в окне начальных установок в группе Схема. Стандартная схема (пункт Стандартная) состоит из 6 точек, расположенных в шести стандартных зонах снимков. Это минимальная схема для взаимного ориентирования.

Расширенная (пункт Расширенная) - из 12 точек, расположенных в шести стандартных зонах снимков. Эта схема позволяет получить более надежные и устойчивые результаты взаимного ориентирования, чем при минимальной схеме.

Можно также создать собственную схему расположения точек. Для этого выберите в группе Схема пункт Произвольная. Появится окно Схема расположения точек для взаимного ориентирования для создания пользовательской схемы расположения точек.

Темно-серая область в этом окне имитирует зону перекрытия левого и правого снимков. Величина зоны перекрытия зависит от базиса фотографирования, указанного в текущем описании фотокамеры. Чем ближе указанный базис будет к реальному, тем точнее будет соответствие между схемой и снимками.

Создавать схему в этом окне следует следующим образом:

1) Чтобы создать новую точку, просто щелкните на нужной позиции в зоне перекрытия. Точка изображается на схеме небольшим зеленым квадратом с номером точки внутри. Последняя созданная точка имеет наибольший номер.

2) Перемещать точки на схеме можно "перетаскиванием". Подведите мышь внутрь квадрата, обозначающего точку (при этом квадрат станет желтым), и перемещайте указатель мыши, удерживая левую кнопку мыши. Точка будет перемещаться синхронно с указателем. Когда точка будет находиться в нужном положении, отпустите левую кнопку мыши.

3) Чтобы удалить точку, воспользуйтесь контекстным меню. Щелкните на изображении точки правой кнопкой мыши, чтобы вызвать контекстное меню. В этом меню выберите пункт Удалить - точка будет удалена.

4) На схеме точки можно помечать. Это полезно при выполнении операций удаления и перемещения точек, поскольку перемещение и удаление затрагивает все помеченные точки. Чтобы пометить непомеченную точку, щелкните на ее изображении мышью. Если щелкнуть мышью на помеченной точке, то пометка с нее снимается.

Чтобы пометить все точки на схеме, используйте команду Пометить всеl из контекстного меню. Чтобы снять пометку со всех точек, выполните команду контекстного меню Снять пометку.

Чтобы удалить все помеченные точки, вызовите контекстное меню щелчком правой кнопки мыши на области перекрытия. В этом меню выберите команду Удалить. Чтобы переместить все помеченные точки в каком-либо направлении, "перетаскивайте" любую из помеченных точек. При этом остальные помеченные точки будут двигаться в том же направлении.

5) Чтобы начать создание схемы сначала, нажмите на кнопку Очистить все в верхней части окна. Все точки схемы будут удалены.

6) Когда создание схемы завершено, нажмите на кнопку OK, чтобы записать схему в файле цифровой модели. Схема должна содержать как минимум 6 точек. Если вы не хотите записывать схему, нажмите на кнопку Отменить. В любом случае программа вернется в окно начальных установок.


Процесс ориентирования

Процесс взаимного ориентирования

При переходе из окна начальных настроек к процессу ориентирования появляется окно Взаимное ориентирование, которое содержит две панели с растровыми образами. Если вы начали процесс ориентирования сначала (выбрали Начать ориентирование в окне начальных установок), программа включает режим управления и переводит марку левого снимка в позицию первой точки на схеме расположения точек.

Далее требуется установить марку левого образа на четкий контур (угол бордюра, угол крыши, поворот дороги, реки, т.п.). Наведите марку на левом образе на нужную точку с помощью мыши или штурвалов. Затем зафиксируйте положение левого образа, удерживая нажатой клавишу Ctrl или нажав на правую двойную педаль и переместите марку правого снимка в ту точку на правом снимке, которая по вашему мнению наиболее соответствует позиции марки на левом снимке. Зарегистрируйте это положение. Программа переместит марку в область следующей точки схемы.

Повторите вышеописанную процедуру для всех точек схемы. При регистрации очередной метки, ее результаты заносятся в таблицу результатов ориентирования. После того, как во всех областях, предусмотреных схемой, зарегистрированы точки, программа выключит режим управления и в таблице результатов будут содержаться окончательные результаты ориентирования.

В процессе ориентирования можно временно выключить режим управления, чтобы произвести коррекцию образа/образов. Чтобы продолжить ориентирование, щелкните на кнопке Дальше, ориентирование продолжится со следующей незарегистрированной точки.

Если в окне начальных установок вы выбрали продолжение последнего процесса ориентирования, то программа не включает режим управления. Марки переводятся в ту позицию, запись которой в таблице помечена синим цветом.

Когда есть более 6-ти включенных точек, можно исключить точку, запись которой в данный момент помечена в таблице. Нажмите кнопку Исключить чтобы исключить точку из расчета результатов ориентирования. Если необходимо включить ранее исключенную точку, нажмите кнопку Включить.

Если режим управления отключен, то можно пометить строку в таблице результатов (щелчком мыши или клавишами-стрелками). При этом марки перемещаются в позицию, соответствующую этой записи. Теперь можно повторить наблюдение этой точки, нажав на кнопку Повтор. Программа включит режим управления и вы сможете сместить марку с ранее зарегистрированной позиции в другое место. После регистрации нового положения этой точки расчет результатов будет произведен заново, а изменения будут занесены в таблицу результатов.


Результаты ориентирования

Результаты взаимного ориентирования

В нижней части окна взаимного ориентирования находятся закладки, на которых результаты ориентирования изображаются в следующей форме:

· На закладке Taблица находится таблица результатов ориентирования, которая начинает отображатся после регистрации координат шести точек. Эта таблица состоит из 4-х колонок:

1) В первой графе отображается порядковый номер зарегистрированной точки.
2) Во второй графе отображается поперечный паралакс (в мкм) для каждой зарегистрированной точки и среднее квадратическое отклонение поперечного паралакса.
3) В третьей графе отображается вес (вклад) каждой точки в среднем квадратическом отклонении паралакса.
4) В четвертой графе отображается состояние точки - включена она (Вкл) в расчет результатов ориентирования или нет (Выкл).

Таблица позволяет повторить регистрацию помеченной точки, включить/исключить ее из расчетов соответственно кнопками Включить или Исключить (подробнее об этом см. "Процесс ориентирования").

Максимальные значения второй и третьей граф отображаются красным цветом. Строки для исключенных точек отображаются серым цветом.

· Величины паралаксов на измеренных точках изображаются на закладке Layout в виде вертикальных линий, выходящих из точек и направленных вверх для точек с положительным паралаксом, и вниз - для точек с отрицательным паралаксом. Для паралаксов, по модулю меньших 5 мкм, линия зеленого цвета, для паралаксов, превышающих 5 мкм, линия красного цвета.

· Закладка Отчет содержит отчет о результатах ориентирования. Отчет содержит полную информацию о результатах взаимного ориентирования снимков. Его можно сохранить в файле (нажав на кнопку Сохранить слева от панели отчета), распечатать (кнопка Печать) или скопировать в буфер обмена Windows (кнопка В буфер). Также можно указать любой доступный в системе шрифт для отчета (кнопка Шрифт).
·


Обзор

Внешнее ориентирование

Раздел предназначен для вычисления элементов внешнего ориентирования цифровой модели. Для расчетов программа использует координаты опорных точек занесенные в файл цифровой модели и измеренные на растровом образе координаты этих точек. При обработке наземных фототеодолитных, аэро- или космических фотоснимков используются также данные описания камеры.

Чтобы войти в раздел абослютного ориентирования нужно нажать на кнопку Moдель на основной панели инструментов программы, а затем выбрать в появившемся меню пункт Внешнее ориентирование. После этого на экране появится окно начальных установок, в котором можно указать, какие образы и как требуется ориентировать.

Затем появляется окно Внешнее ориентирование стереопары, Ориентирование двух одиночных снимков или Ориентирование одиночного снимка, где и производится собственно процесс ориентирования с регистрацией точек.

Результаты внешнего ориентирования записываются в файл цифровой модели. Для снимков в формате TIFF Tiled результаты внешнего ориентирования записываются в файл снимка, что позволяет сделать снимок независимым от файла цифровой модели.


Системы координат

После ориентирования снимков, полученных при помощи аэрофотосъемки, наземной съемки и сканированных карт координаты объектов при обработке цифровой модели будут формироваться в системе координат опорных точек. Для снимков космической съемки, сканерных космических снимков, космических ортоснимков необходимо указать систему координат для формируемой цифровой карты. Космические сканерные снимки (Ikonos, QuickBird и др.) поставляются с коэффициентами рациональных полиномов, которые задают математическую модель пересчета координат объекта (широта, долгота и высота) на эллипсоиде WGS84 в координаты на снимке. Для согласования таких снимков с существующими векторными картами в системе СК-42 необходимо задавать правила пересчета из WGS84 в СК-42 и даже в СК-63, коэффициенты перехода в которую закрыты. Космические ортоснимки (IRS и др.) поставляются в формате GeoTIFF или с мировым файлом (World File), в которых указаны координаты верхнего пиксела в широте, долготе на WGS84. Для таких снимков тоже необходим переход в СК-42 или СК-63. Для этих целей служит текстовый файл Datums.ini, в котором можно задать параметры требуемых эллипсоидов и правила перехода из системы координат WGS84(UTM) в нужную систему координат.

Правила формирования файла.

1. Файл разбит на секции. Первая строка каждой секции задает имя секции в квадратных скобках. Это имя будет включаться в выпадающий список систем координат. Одна секция задает либо описание одного эллипсода или правила пересчета из WGS64 в другую систему координат. Все значения параметров секции имеют ключевой формат <имя параметра>=<значение параметра>. Строка, которая начинается с символа <;>(точка с запятой), считается комментарием и не обрабатывается.

2. В секции можно указать следующие параметры:
а) а=<значение> - величина большой полуоси эллипсоида в м. Значение = 0 или отсутствие этого параметра служит признаком для программы, что эллипсоид использовать не надо;
б) f=<значение> - величина, обратная коэффициенту полярного сжатия;
в) Scale=<значение> - значение масштаба на центральном меридиане зоны. Для проекции UTM - 0.9996, для проекции Гаусса-Крюгера - 1.
г) FalseEast=<значение> - восточное смещение для координаты в зоне, м. Для UTM СК-42 - 500000;
д) FalseNorth=<значение> - северное смещение для координаты в южном полушарии (10000000 м);
е) PrimeMeridian=<значение> - начальный меридиан для отсчета зон, градусы. Для UTM - -180 градусов, для СК-42 - 0 градусов от Гринвича;
ж) AddZone=<значение> - признак, указывающий на необходимость добавления номера зоны в координату. Если значение /= 0, то добавлять;
з) Helmert=<значения> - семь коэффициентов Хельмерта для пересчета из указанного в секции эллипсоида в WGS84. Указываются только для пересчетных секций;
и) TiePoint<n>=<значения координат X,Y одной и той же точки в двух плоских системах координат> - для указания до 10-ти связующих точек, определяющих пересчет координат из одной плоской системы координат в другую.

Пример.

[WGS84 <-> SK63]
a=6378245
f=298.3
Scale=1.0
FalseEast=500000
FalseNorth=0
PrimeMeridian=0
AddZone=0
Helmert=25.0 -141 -78.5 0.0 -0.35 -0.736 0.0
;
TiePoint1=5460000.68 7557000.39 5455267.625 6393988.836
TiePoint2=5340000.64 7491000.87 5338635.023 6328401.011
TiePoint3=5330000.20 7626000.50 5321515.39 6363237.59
TiePoint4=5540000.30 7444000.20 5538840.90 6280465.80

Эта секция задает пересчет из координат широта, долгота, высота на WGS84 в координаты X, Y, Z в системе
СК-63.


Начальные установки

Начальные установки для внешнего ориентирования модели

Для того, чтобы выполнить внешнее ориентирование цифровой модели, необходимо определить следующие исходные данные и параметры ориентирования.

· Указать один из следующих видов съемки в группе Вид съемки:

1) Aeрофото - аэрофотосъемка (стереопара или одиночный снимок центральной проекции). Позволяет включить флажки учета кривизны Земли и учета рефракции атмосферы Земли;
2) Космическая центральная - космическая съемка (стреопара или одиночный снимок центральной проекции);
3) Космическая панорамная - панорамная космическая съемка (обработка одиночных снимков);
4) Карта - сканированные планы и карты;
5) Наземная съемка - наземная фототеодолитная съемка;
6) Сканерная цифровая - космическая сканерная съемка;
7) Архитектурная - съемка зданий, строений, сооружений с разных сторон с опорой в одной системе координат. Система координат должна быть левосторонней (Гаусса-Крюгера) и иметь следующие направление осей для съемки сверху:
ось Х - на Север,
ось Y - на Восток,
ось Z - вверх от земной поверхности.
Относительно такой системы координат съемка с юга - фронтальная, с запада - слева, с востока - справа, с севера - сзади. Координаты опорных точек и точек стояния для всех направлений съемки необходимо указывать в съемке сверху. Из выпадающего списка необходимо указать направление съемки относительно съемки сверху. Программа выполнит ориентирование модели и ее обработку в системе координат, соответствующей направлению съемки. Результаты всей обработки можно перевести в одну систему координат (программа Ged.exe - Карта | Система координат) и передать в программу, позволяющую рассмотреть результаты в объемном изображении.

· Указать, будет ли ориентироваться стереомодель (Стереопара или Два одиночных снимка) или одиночный образ (Одиночный снимок) в группе Метод ориентирования. Метод Два одиночных снимка используется для создания стереомодели без процесса взаимного ориентирования снимков. В некоторых случаях (съемка длиннофокусным объективом, наземная съемка с небольшим базисом) взаимное ориентирование снимков дает неустойчивые результаты и не позволяет получить стереомодель требуемой точности. Кроме того, ориентирование двух одиночных снимков позволяет использовать все опорные точки снимка, а не только точки в зоне перекрытия.
· open Укажите имя одного или двух файлов растровых образов. Для указания имен файлов существуют два поля ввода для левого и правого снимков стереопары (Левый снимок и Правый снимок) с соответствующими кнопками слева от них. При ориентировании одиночного образа его имя указывается в поле ввода Левый снимок. Для выбора имени файла/файлов можно либо ввести его имя в нужном поле ввода, либо щелкнуть на соответствующей кнопку с изображением папки. В последнем случае появится стандартное диалоговое окно Windows для указания имени файла. После выбора файла с помощью этого окна его имя отобразится в поле ввода.Группа исходных данных Исходные значения служит для задания начальных значений элементов ориентирования. Если из каких то источников известны приближенные или точные значения элементов, то их рекомендуется указать как начальные значения. Это может ускорить решение задачи ориентирования.

· fix2 Если известны координаты точки фотографирования и эти значения не должны изменяться в процессе решения задачи, то их необходимо зафиксировать, используя кнопки Fixed. Если известны и фиксируются все элементы ориентирования, необходимые для создаваемой модели, программа использует эти данные для формирования невязок на опорных точках (если они указаны) и переходит в режим показа результатов формирования цифровой модели.
· Для наземной фототеодолитной съемки можно указывать дополнительные параметры:
- Slope(Скос) - отклонение оси фотографирования от перпендикуляра к базису фотографирования в градусах со знаком минус при отклонении вправо и знаком плюс - влево. В поле Left(левый) указывается скос в левой точке базиса, в поле Right(правый) - скос в правом конце базиса. Таким образом можно указать параметры различных видов съемки;
- Lens shift(Сдвиг объектива) - сдвиг объектива камеры по вертикали во время съемки.
Нажатием кнопки Детали...можно вызвать окно для формирования параметров наземной съемки

· Для космической сканерной или щелевой съемки нажатие кнопки Детали...можно вызвать окно для просмотра и формирования параметров этого вида съемки(Параметры сканерной съемки).

· Укажите, надо ли начинать процесс ориентирования сначала (Начать ориентирование) или следует продолжить последний проведенный процесс (Продолжить) в группе Стадия.

Есть возможность использовать результаты ориентирования или измерений, полученные в процессе сгущения сети или измерений на других приборах. Для этого необходимо указать пункт Загрузить измерения из файла и нажать кнопку Читать данные... В появившемся окне необходимо указать формат данных, используемых для загрузки. Список форматов данных формируется из файла описания форматов Models.fmt. Первый формат данных (Фотоблок) является предопределенным и в файле описания форматов не содержится. Этот формат имеет сложную структуру и обрабатывается по отдельному алгоритму. Если в загружаемом файле содержатся координаты опорных точек и координаты точек, измеренных на снимке, программа вычислит элементы внешнего ориентирования и покажет результаты ориентирования. Эти элементы можно будет сохранить в файле цифровой модели Models.ini, а также в самых цифровых образах снимков. Если же в файле содержатся готовые элементы ориентирования, программа перепишет их в файл цифровой модели и в растровые образы снимков. Результат переноса элементов отобразится в специальной форме.
· С помощью кнопки Add ground point... можно добавить опорные точки для ориентирования модели. Точки будут дописываться в файл цифровой модели. За одно нажатие кнопки можно добавить одну точку. В появившемся окошке необходимо указать через пробелы: идентификатор точки и координаты X,Y и Z (в системе X на север).

· Когда все описанные выше настройки произведены, можно приступать собственно к процессу ориентирования, нажав на кнопку Выполнить. Если вы не хотите начинать ориентирование, нажмите на кнопку Отменить.


Файл форматов данных

Процесс внешнего ориентирования можно упростить и ускорить, прочитав из файла данные, необходимые для вычисления элементов внешнего ориентирования или готовые элементы внешнего ориентирования. Для этого используется файл описания форматов данных, в котором приводится структура данных в загружаемом файле. Имя файла - Models.fmt. Он должен находится в папке с программами пакета "Дельта".

Файл формируется и редактируется в любом текстовом редакторе и не должен содержать элементов форматирования. В описании формата используются ключевые слова из букв латинского алфавита. Разделителем между словами может быть пробел или табуляция.
Описание каждого формата располагается внутри блока, обозначаемого словами

BEGIN FORMAT
END FORMAT

Все комментарии к формату должны располагаться за пределами блока описания (перед ним или после него).
Само описание состоит из заглавия, в котором указывается общая информация о формате и, собственно, описание обрабатываемой информации.
Заглавие должно начинаться словом

TITLE:

В заглавии может быть указана следующая информация:

Name='...' - наименование формата. Это обязательный параметр, в котором указывается условное наименование формата, которое будет помещено в выпадающий список форматов и которым один формат бкдет отличаться от другого. Имя формата должно заключаться в одиночные кавычки (латинский алфавит).
Например: Name='Ground+Measures', Name='PhotoMod'.

Type={G+M | G&M | E} - тип считываемых данных. Параметр обязательный.
G+M - в одном файле указаны координаты опорных точек и измеренные координаты соответствующих им точек на левом (и правом - для стерео) снимке;
G$M - Координаты опорных точек и измеренные на снимке(ах) координаты точек содержатся в разных файлах;
E - в файле указаны элементы ориентирования снимка(ов).

Ext=...;... - список возможных фильтров для файла данных.
Например: Ext=*.txt;*.dat, Ext=*.ori.
Параметр не обязательный. Если не указан, то для поиска файла данных в выбранной папке будут показаны все файлы.

XYZ={M | F} - единицы измерения координат опорных точек или точек фотографирования. Возможны два значения:
M - координаты в метрах,
F - координаты в футах.
Параметр не обязательный. По умолчанию - координаты в метрах.

xy={mm | mcm} - единицы измерения координат на снимке. Возможны два значения:
mm - координаты в миллиметрах,
mcm - координаты м микрометрах.
Параметр не обязательный. По умолчанию - координаты в миллиметрах.

Angle={D | G | R} -единицы измерения углов:
D - углы в градусах (первая буква от Degree - градус),
G - углы в градах (первая буква от Gon},
R - углы в радианах (первая буква от Radian).
Параметр не объязательный По умолчанию - углы в градах (сотые доли от прямого угла, 1 оборот - 400 град).

Instr=n - параметр показывает наличие и количество измерений меток на снимках. Если измерений меток нет, то параметр должен отсутствовать или Instr=0. Если измерения меток есть, они должны быть первыми в файле измерений.

Key='...' - ключевое слово в строке файла данных, после которой располагается обрабатываемая по формату информация. Таким образом, файл данных может состоять из двух частей:
в начале файла содержится вспомагательная необрабатываемая часть, завершающаяся строкой с ключевым словом,
вторая часть содержит обрабатываемую по формату информацию.
Ясно, что в первой части не должно быть строки (кроме последней), содержащей ключевое слово.

PhotoKey='...' - ключевое слово, по которому определяется начало информации очередного снимка, стереопары и т.п. Использование ключевого слова позволяет пропускать записи файла, информация которых не используется. Если ключевое слово не указано, будут обрабатываться все записи файла в соответствии с описанием. При использовании ключа будет обрабатываться столько строк очередного снимка, сколько указано в описании формата. Все последующие строки до встречи с ключевым словом будут пропущены. Обработка данных снимка начинается со строки, содержащей ключ. Если в этой строке нет обрабатываемой информации (кроме ключа), то описание информации необходимо начинать с пустой строки.

Все параметры заглавия можно располагать в одной строке или в отдельных строках.

Описание самого формата данных должно начинаться со слов

FORMAT:

Если данные расположены в двух файлах (Type=D&M), то описание формата должно состоять из двух секций, которые должны начинаться со слов:

GROUND: - для описания формата файла опорных точек,

MEASURES: - для описания формата файла координат точек на снимках.

В описании формата можно указать:

Знак * (звездочка) на месте показателя, который не надо обрабатывать. Этот знак можно не ставить на месте показателей, которые идут после последнего обрабатываемого показателя.

PhotoN - на месте номера сника.

N - на месте номера (идентификатора) точки.

X - на месте координаты X опорной точки или точки фотографирования.

Y - на месте координаты Y опорной точки или точки фотографирования.

Z - на месте координаты Z опорной точки или точки фотографирования.

Внимание! При указании расположения координат X и Y для опорных точек необходимо выбирать такой порядок, чтобы они после считывания были в системе Гаусса-Крюгера (X на север). Так, если в файле координаты опорных точек в системе Гаусса-Крюгера, то необходимо указывать порядок координат X Y Z, иначе Y X Z.
Для элементов ориентирования координаты точки фотографирования необходимо приводить в систему X по экватору.

Для указания координат точек на снимке исполтьзуются:

XL - координата X на левом снимке.

YL - координата Y на левом снимке.

XR - координата X на правом снимке.

YR - координата Y на правом снимке.

Если обрабатываются координаты одного снимка, то считается, что это левый снимок.

Для обработки углов наклона снимков используются слова:

Omega - угол поворота вокруг оси X (первичная ось) против часовой стрелки.

Phi - угол поворота вокруг оси Y против часовой стрелки.

Kappa - угол поворота вокруг оси Z против часовой стрелки.

Для углов по часовой стрелке перед соответствующим ему словом необходимо указывать знак -(минус).
Система координат правая.
Это наиболее широко используемое соглашение, рекомендуемое ISPRS.
При использовании других систем вращения необходимо приводить их к системе, рекомендуемой ISPRS.
Система Alpha, Omega, Kappa (Фотограмметрия, Ф.Н.Лобанов) соответствует -Phi, Omega, Kappa.
Пример. Типичный перевод в систему Omega, Phi, Kappa (из Alpha, Omega, Kappa).
В заглавии необходимо указать:
Type=E - ввод элементов ориентирования,
Angle=D - углы в градусах.
В секции описания формата углы указываются следующим образом:
... -Phi Omega Kappa.

Для обработки направляющих косинусов используются обозначения, приведенные в следующей матрице:

| A11 A12 A13 |
| A21 A22 A23 |
| A31 A32 A33 |.

Эта матрица соответствует последовательности поворотов Omega, Phi, Kappa.
Для другой последовательности углов и направлений поворотов необходимо указать порядок обработки и знаки напрвляющих косинусов, обеспечивающие приведение к указанной матрице.

Пример. Типичный порядок обработки направляющих косинусов из системы Alpha, Omega, Kappa:
A22 A21 A23 A12 A11 A13 A32 A31 A33.

Образцы описания форматов
--------------------------------------
Описание формата файла,содержащего координаты опорных точек и координаты точек на снимках одной стереопары. Каждая строка файла данных должна иметь одинаковую структуру.

================================
BEGIN FORMAT
TITLE: Name='Ground and Measures' Type=G+M Ext=txt;dat
FORMAT:
N X Y Z XL YL XR YR
END FORMAT
================================

Описание файла, содержащего элементы ориентирования снимков - координаты точки фотографирования и углы наклона снимка в системе Alpha, Omega, Kappa. Одно число после номера снимка будет пропускаться. Координаты - в системе X на север.

================================
BEGIN FORMAT
TITLE: Name='Alpha,Omega,Kappa' Type=E Ext=txt;dat Angle=D
FORMAT:
PhotoN * Y X Z -Phi Omega Kappa
END FORMAT
================================

Описание файла, содержащего элементы ориентирования снимков - координаты точки фотографирования и направляющие косинусы снимка в системе Alpha, Omega, Kappa. Атрибут после номера снимка будет пропускаться. Координаты в системе X по экватору. Элементы одного снимка располагаются в трех строках файла.

================================
BEGIN FORMAT
TITLE: Name='Ori(3 lines)' Type=E Ext=ori
FORMAT:
PhotoN * X Y Z
A22 A21 A23 A12 A11
A13 A32 A31 A33
END FORMAT
================================

Описание формата файла, содержащего координаты опорных точек стереопары в одном файлй, а координаты точек на снимках - в другом файле. Система координат опорных точек - X на север.

================================
BEGIN FORMAT
TITLE: Name='Ground&Measures' Type=G&M Ext=txt;dat
FORMAT:
GROUND:
N X Y Z
MEASURES:
N XL YL XR YR
END FORMAT
================================

Описание формата с использованием ключевого слова. Файл содержит координаты точки фотографирования, напрвляющие косинусы и углы поворота снимков. Формат составлен для использования углов поворота.

================================
BEGIN FORMAT
TITLE: Name='Photos exterior' Type=E Ext=txt;dat PhotoKey='Снимок:'
FORMAT:
* PhotoN
* * X Y Z

* -Phi * Omega * Kappa
END FORMAT
=================================

Описание формата файла, состоящего из двух частей, разделенных ключевым словом.

================================
BEGIN FORMAT
TITLE: Name='Adjast' Type=E Ext=0 Key='Start'
FORMAT:
PhotoN

X Y Z
Omega Phi Kappa
END FORMAT
================================

Пакет программ "Дельта" содержит файл Models.fmt, в котором уже приведены описания основных форматов данных.


Параметры фототеодолитной съемки

Параметры фототеодолитной съемки можно указать в специальном окне, которое позволяет:
а) ввести координаты левого и правого концов базиса фотографирования;
б) ввести координаты точек визирования из левого и правого концов базиса;
в) сдвиг объектива камеры при фотографировании в левом и правом концах базиса;
г) отклонение оптической оси камеры от перпендикуляра к базису (скос).

Процесс формирования этих параметров можно упростить, если координаты концов базиса и точек визирования подготовить заранее в текстовом редакторе и запомнить в текстовом файле. Эти точки можно загрузить в окно Каталог точек. Используя кнопки В буфер и Из буфера для точки каталога, на которой стоит курсор, можно скопировать значение координат любой точки каталога в нужный параметр наземной съемки.
Для ускорения поиска нужной точки в каталоге служит поле ввода Поиск точки, в котором указывается идентификатор нужной точки.
Если известны точки визирования и они активизированы (флажок взведен), то можно вычислить скосы оси камеры в левом и правом концах базиса, нажав кнопку Вычислить.
Кнопка X<--->Y позволяет поменять местами координаты X и Y точек каталога. Координаты точек каталога должны быть в системе X на север.


Общие положения

Для ориентирования снимков космической сканерной съемки в программе реализованы следующие методы:
1. Использование параметров сенсора и параметров оптической системы камеры. Значения интенсивностей, формируемые сенсором(ПЗС-линейкой), должны располагаться вертикально в растровом изображении. Направление полета слева-направо. Число элементов сенсора определяется из высоты изображения. Фокусное расстояние, смещение главной точки и размеры снимка указываются в описании камеры. Угол наклона оптической оси камеры относительно надира указывается в угол альфа в начальных установках для ориентирования.
2. Использование рациональных полиномов (RPC). Для снимков высокого разрешения (Ikonos, QuickBird).
3. 3D аффинное преобразование.
4. 3D Direct Linear Transformation (DLT) преобразование.
5. 3D Parallel Perspective Transformation (PPT) преобразование.

Использование RPC позволяет обрабатывать снимки без дополнительной привязки. Карта при этом будет в системе координат WGS84 и проекции UTM (датум WGS84).

Методы 2-5 используются для ориентирования изображений, полученных с помощью узкоугольной съемки. при наличии RPC лучше использовать метод 2, при их отсутствии - более стабильно работает метод 3. Методы 2-5 дают приблизительно одинаковую точность модели.

Использование этих методов ориентирования позволяет получить математическую модель для пересчета пространственных координат (широта, долгота и высота) на эллипсоиде WGS84 в координаты на снимке. Если опорные точки указываются в другой системе координат (например в СК-42), то необходимо использовать пересчетный датум (WGS84 <-> SK42).


Параметры сенсора

Для космической сканерной и щелевой съемки внешнее ориентирование выполняется в режиме Два одиночных снимка. Используется два метода ориентирования снимков:
метод, предложенный С.В.Агаповым (далее метод A),
метод динамических элементов (далее метод D).

В зависимости от выбранного метода в окне отображются следующие параметры:

· общие параметры:
параметры вспомогательной фотограмметрической системы. Координаты начала фотограмметрической системы в Гринвической геоцентрической системе координат. Ось X фотограмметрической системы направлена на север.
элементы ориентирования базовой строки левого снимка,
элементы ориентирования базовой строки правого снимка.
· для метода A:
угол направления полета в фотограмметрической системе (тау),
коэффициент пропорциональности вдоль оси полета.
· для метода D:
- степени полиномов аппроксимации динамических элементов ориентирования. Степени могут принимать значения от 0 до 3. Нулевое значение степени используется для отмены аппроксимации элемента ориентирования (элемент статический). Степени полиномов для левого и правого снимков совпадают,
- коэффициенты полиномов аппроксимации. Обозначение коэффициентов Kij.
Индекс i - номер элемента (1 - X0, 2 - Y0, 3 - Z0, 4 - альфа, 5 - омега, 6 - каппа).
Индекс j - степень слагаемого, в состав которого входит коэффициент.

Все угловые параметры приведены в градусах.

Окно просмотра и формирования параметоров можно вызвать перед началом ориентирования, нажав кнопку Детально... в окне начальных установок. В это время параметры фотограмметрической системы еще не сформированы и значения их нулевые. Указанные в окне параметры используются как начальные значения для ориентирования снимков.
В процессе ориентирования снимков окно просмотра тоже можно вызвать и изменить значения параметров. Если модель уже создана, элементы ориентирования будут определены с учетом изменений. Если программа не сможет определить элементы ориентирования с учетом изменений, она вернет предыдущие значения параметров.


Рациональные полиномы

Компания Space Imaging, поставляющая спутниковые сканерные изображения высокого разрешения (Ikonos, QuickBird), защищает свои права собственности на точные данные о параметрах оптико-электронной системы камеры спутника. Вместо этих данных компания с каждым изображением поставляет математическую модель камеры в виде коэффициентов рационального полинома (RPC - rational polynom coefficients camera model). Эта модель выражает связь между пространственными характеристиками объекта (широта, долгота и высота) и пространственными характеристиками объекта на снимке. С использованием модели снимки можно обрабатывать без дополнительной привязки. Однако при разрешении снимков <= 1 м максимальная погрешность определения координат объектов может достигать 20-25 м. Повысить точность модели можно при помощи дополнительного ориентирования снимка по опорным точкам. Наличие даже одной опорной точки может существенно повысить точность модели. Оптимальным числом опорных точек является 5-10. Дальнейшее повышение числа опорных точек не приводит к повышению точности модели.


3D аффинное преобразование, 3D DLT, 3D PPT

3D аффинное, 3D DLT и 3D PPT преобразования являются алтернативой при отсутствии коэффициентов рациональных полиномов (RPC) и параметров оптико-электронной системы камеры. Они реализуют различные математические модели камеры, позволяющие выполнить пересчет пространственных координат (широта, долгота и высота) на эллипсоиде WGS84 в координаты на снимке. Наиболее стабильно работает ориентирование снимков по опорным точкам с помощью 3D аффинного преобразования. Все три метода ориентирования дают приблизительно одинаковую точность модели.


Процесс ориентирования

Процесс абсолютного ориентирования

При переходе из окна начальных настроек к процессу ориентирования появляется окно Внешнее ориентирование, которое содержит одну или две панели с растровыми образами в зависимости от выбранного метода ориентирования. В этом окне нужно зарегистрировать положения опорных точек. Программа не имеет информации о расположении первых двух опорных точек на снимках.

Для ориентирования стереопары необходимо использовать стереоскоп для стереоскопического наблюдения модели местности. При укомплектовании компьютера стереоочками внешнее ориентирование модели можно выполнить с помощью стереоочков.

С помощью мышки или штурвалов установите марку на первую опорную точку. При ориентировании стереопары сначала установите марку на опорную точку на левом образе, потом, вращением ножного штурвала или перемещением мыши (последнее при нажатой клавише Ctrl) устранить продольный паралакс на опорной точке. Нажатием левой клавиши мыши или одиночной педали зарегистрируйте координаты точки.

После регистрации первой опорной точки программа снова переместит марку в центр образа. Для второй опорной точки повторить процесс, указанный для первой точки.

Для последующих точек программа автоматически перемещает марку в область очередной опорной точки. Порядок их регистрации такой же, как для первой и второй точек.

Замечание: Все точки необходимо измерять, соблюдая очередность их следования в описании опорных точек. Идентификатор очередной опорной точки указываются в строке статуса программы в самой нижней части окна ориентирования.

Этот процесс продолжается пока не будут зарегистрированы координаты всех опорных точек, указанных для формирования цифровой модели. В процессе измерений формируется таблица результатов. После регистрации последней опорной точки программа выключит режим управления и в таблице результатов будут содержаться окончательные результаты ориентирования.

В процессе ориентирования можно временно выключить режим управления, чтобы произвести коррекцию образа/образов. Чтобы продолжить ориентирование, щелкните на кнопке Дальше, ориентирование продолжится со следующей незарегистрированной точки.

Если в окне начальных установок вы выбрали продолжение последнего процесса ориентирования, то программа не включает режим управления. Марка/марки переводится в ту позицию, запись которой в таблице помечена синим цветом.

Когда число включенных точек больше минимального, можно исключить точку, запись которой в данный момент помечена в таблице. Нажмите кнопку Исключить чтобы исключить точку из расчета результатов ориентирования. Если необходимо включить ранее исключенную точку, нажмите кнопку Включить.

Если режим управления отключен, то можно пометить строку в таблице результатов (щелчком мыши или клавишами-стрелками). При этом марка/марки перемещаются в позицию, соответствующую этой записи. Теперь можно повторить наблюдение этой точки, нажав на кнопку Повторно. Программа включит режим управления и вы сможете сместить марку с ранее зарегистрированной позиции в другое место.


Ориентирование двух одиночных снимков

Метод Два одиночных снимка используется для создания стереомодели без процесса взаимного ориентирования снимков. В некоторых случаях (съемка длиннофокусным объективом, наземная съемка с небольшим базисом) взаимное ориентирование снимков дает неустойчивые результаты и не позволяет получить стереомодель требуемой точности. Кроме того, ориентирование двух одиночных снимков позволяет использовать все опорные точки снимка, а не только точки в зоне перекрытия. Поскольку снимки могут содержать индивидуальные и общие опорные точки, процесс ориентирования такой стереопары имеет некоторые особенности, отличающие его от ориентирования стереопары после взаимного ориентирования. Перечислим эти особенности.

· Список опорных точек для ориентирования должен содержать все опорные точки двух снимков.
· При включенном управлении оба снимка движутся синхронно, при нажатой клавише <Ctrl> или правой двойной педали движется только правый снимок.
· Регистрацию точек можно выполнять на каждом снимке отдельно. Для регистрации точки только на левом снимке необходимо удерживать клавишу <Ctrl>, только на правом - клавишу <Alt>.
· Аналогично можно исключать/включать зарегистрированные точки на каждом из снимков.
· Есть две таблицы результатов ориентирования. Для моно режима показываются результаты ориентирования каждого снимка. Для стерео режима - результаты ориентирования стереомодели на общих точках.
·


Результаты ориентирования

Результаты абсолютного ориентирования

В нижней части окна взаимного ориентирования находятся закладки, на которых результаты ориентирования изображаются в следующей форме:

· На закладке Таблица находится таблица результатов ориентирования. Эта таблица состоит из следующих колонок:

1) В первой колонке отображается идентификатор зарегистрированной точки.
2) Во второй колонке отображается отклонение измеренной координаты X от указанной в описании. В круглых скобках указывается вес (вклад) отклонения X точки в среднем квадратическом отклонении.
3) В третьей колонке отображается отклонение измеренной координаты Y от указанной в описании. В круглых скобках указывается вес (вклад) отклонения Y точки в среднем квадратическом отклонении.
4) В четвертой колонке отображается отклонение измеренной координаты Z от указанной в описании. В круглых скобках указывается вес (вклад) отклонения Z точки в среднем квадратическом отклонении.
5) В последней строке таблицы указываются средние квадратические отклонения измеренных координат опорных точек от указанных в описании.

Таблица позволяет повторить регистрацию помеченной точки, включить/исключить ее из расчетов соответственно кнопками Включить или Исключить (подробнее об этом см. "Процесс ориентирования").

Максимальные значения второй и третьей и четвертой колонок отображаются красным цветом. Строки для исключенных точек отображаются серым цветом.

· Закладка Отчет содержит отчет о результатах ориентирования. Отчет содержит полную информацию о результатах внешнего ориентирования снимков. Его можно сохранить в файле (нажав на кнопку Сохранить слева от панели отчета), распечатать (кнопка Печать) или скопировать в буфер обмена Windows (кнопка В Буфер). Также можно указать любой доступный в системе шрифт для отчета (кнопка Шрифт).


Меню

Головное меню содержит два раздела:

Файл Управление Точки.

Раздел Файл содержит команду Файл | Выход F10. Команда дублирует действие кнопки "Выход".

Раздел Управление содержит следующие команды:

Управление | Включить - включить управление растровыми образами. Дублирует действие кнопки "Захват".
Управление | Выключить - выключить управление растровыми образами. Дублируется клавишей Esc.
Управление | Дальше - необходима для продолжения приостановленного процесса ориентирования. Дублирует действие кнопки "Дальше".
Управление | Повторно - необходима для повторного наведения и регистрации уже зарегистрированной точки. Дублирует действие кнопки "Повторно".
Управление | Исключить(Включить) - необходима для исключения или включения одной из зарегистрированной точек при определении элементов ориентирования. Дублирует действие кнопки "Исключить(Включить)".
Управление | Реверс стерео - изменяет полярность стереоочков(переключение стереоэффекта из прямого на обратный).
Управление | Стереоскоп - используется стереоскоп.
Управление | ASUS VR3800 очки - используются стереоочки с видеоплатой ASUS VR3800.
Управление | ASUS VR6600 очки - используются стереоочки с видеоплатой ASUS VR6600.
Управление | Open GL очки - используются возможности Open GL для видеокарт NVidia..
Управление | Анаглиф - используется стереоэффект с помощью разделения цветов с помощью очков с двумя сфетофильтрами. В дополнительном меню необходимо указать одно из воможных сочетаний светофильтров, соответствующее используемым очкам. .

Если щелкнуть правой клавишей мышки на таблице результатов, то активизируется контексное меню, дублирующее команды раздела Управление основного меню.

Раздел Точки содержит следующие команды:

Точки | Точки в файл... - позволяет после завершения внешнего ориентирования модели регистрировать произвольные точки и записывать их геодезические координаты в текстовый файл. Если указанный файл уже существует, то новые точки будут добавляться в конец файла, иначе сначала будет создан новый файл с указанным именем. В файл записываются идентификатор точки(запрашивается для каждой зарегистрированной точки) и координаты X, Y, Z, разделенные пробелами. Координаты точки сформированы в системе X на север.
Точки | Редактировать опору... - вызвать программу для работы с опорными точками.
Точки | Добавить опорную точку... - позволяет после завершения внешнего ориентирования модели добавить опорную точку для цифровой модели и использовать ее для ориентирования модели. Для этого вызывается окно редактирования, в котором необходимо указать идентификатор точки и координаты X, Y, Z, разделенные пробелами. Координаты точки должны быть в системе X на север.
Точки | Редактировать опорную точку... - позволяет после завершения внешнего ориентирования модели редактировать опорную точку для цифровой модели и использовать ее для ориентирования модели. Для этого вызывается окно редактирования, в котором необходимо указать идентификатор точки и координаты X, Y, Z, разделенные пробелами. Координаты точки должны быть в системе X на север.
Точки | Показать опору - включает/отключает отображение положения опорных точек на снимках. Координаты опорных точек на снимках, зарегистрированные в процессе внешнего ориентирования модели, записываются в растровые образы снимков(для файлов формата .tif и .dip). Это позволяет (при включенном отображении опоры) видеть расположение опорных точек на снимках и контролировать правильность их регистрации. Этот пункт дублируется флажком Показать опору на панели инструментов. Если координаты олорных точек отсутствую в растровом образе, то после ориентирования модели их положениие определяется с помощью элементов ориенттирования.
Точки | Учет кривизны Земли - включает/отключает учет кривизны при ориентировании аэрофотоснимков.
Точки | Учет рефракции атмосферы - включает/отключает учет рефракции атмосферы Земли при ориентировании аэрофотоснимков.
Точки | Знаков в дробной части - в дополнительном меню указать число десятичныз знаков (0-4) для отображения результатов ориентирования. Это позволяет оптимизировать отображение результатов для съемки разных масштабов.


Преобразование в эпиполярную систему

Преобразование снимков в эпиполярную систему координат

Если для стереопары снимков углы взаимного ориентирования имеют значительную величину, а также в некоторых других случаях есть необходимость в преобразовании снимков в эпиполярную систему координат. Такое преобразование можно выполнить после завершения взаимного ориентирования снимков. Если же взаимное ориентирование не выполнялось (ориентировались одиночные снимки или элементы внешнего ориентирования получены из триангуляции), можно преобразовать снимки в эпиполярную систему координат по элементам внешнего ориентирования.

Для преобразования используется специальное окно, в котором необходимо указать имена снимков исходной модели и имена снимков для модели в эпиполярной системе координат. При нажатии кнопки Выполнить программа преобразует снимки в эпиполярную систему. Для больших снимков этот процесс может занимать время от нескольких минут до нескольких десятков минут. Процесс преобразования отображается на индикаторе. Кнопка Cancel на индикаторе позволяет прерват процесс преобразования.

При преобразовании снимков в эпиполярную систему координат можно выбрать следующие методы формирования пикселей эпиполярного изображения:
- перенос. Новый пиксел получается простым переносом соответствующего пиксела исходного преобразования;
- билинейное усреднение. Новый пиксел получается усреднением 4-х ближайших пикселей исходного изображения;
- гауссиан 3х3. Новый пиксел получается посредством преобразования матрицы 3х3 исходных пикселей через коэффициенты распределения Гаусса;
- гауссиан 5х5. Новый пиксел получается посредством преобразования матрицы 5х5 исходных пикселей через коэффициенты распределения Гаусса.
Метод переноса самый быстрый, но при его применении на прямолинейных контурах могут образовываться неровности. Методы 2-4 позволяют сглаживать эти неровности. Методы расположены по возрастанию времени преобразования. Для большинства случаев оптимальным является метод билинейного усреднения.


Устранить каппа

Если элементы ориентирования снимков получены после триангуляции блока аэрофотосъемки и углы наклона снимков в маршруте значительно отличаются, то для улучшения стереосбора есть возможность устранить различия в углах наклона для всех снимков маршрута в групповом режиме (Внешнее ориентирование|Устранить каппа). При выполнении этой команды появляется окно, в котором необходимо указать следующие данные:
1) список преобразуемых снимков в пределах выбранного маршрута;
2) папку для записи преобразованных снимков. Если эта папка совпадает с папкой с исходными снимками, программа выдаст запрос на продолжение работы. При утвердительном ответе преобразование выполняется через рабочий файл. После завершения преобразования очередного снимка к имени исходного файла добавляется расширение ".bak", а рабочему файлу присваивается имя исходного файла;
3) программа выводит минимальное и максимальное значение угла каппа для всего списка снимков, а также среднее значение каппа, которое будет установлено для всех снимков списка. Это значение можно изменять;
4) включить или отключить создание пирамиды для преобразованных снимков;
5) при достаточном объеме оперативной памяти можно указать предварительную загрузку всего снимка в оперативную память, что может ускорить преобразование снимка.
Преобразование каждого снимка отображается в индикаторе процесса. Этот индикатор позволяет прервать процесс преобразования.
После успешного преобразования снимка новые элементы ориентирования для него записываются в файл стереомоделей Models.ini и в файл преобразованного снимка.

При преобразовании снимков из выпадающего списка можно выбрать следующие методы формирования пикселей эпиполярного изображения:
- перенос. Новый пиксел получается простым переносом соответствующего пиксела исходного преобразования;
- билинейное усреднение. Новый пиксел получается усреднением 4-х ближайших пикселей исходного изображения;
- гауссиан 3х3. Новый пиксел получается посредством преобразования матрицы 3х3 исходных пикселей через коэффициенты распределения Гаусса;
- гауссиан 5х5. Новый пиксел получается посредством преобразования матрицы 5х5 исходных пикселей через коэффициенты распределения Гаусса.
Метод переноса самый быстрый, но при его применении на прямолинейных контурах могут образовываться неровности. Методы 2-4 позволяют сглаживать эти неровности. Методы расположены по возрастанию времени преобразования. Для большинства случаев оптимальным является метод билинейного усреднения.


Создать анаглиф

Создать анаглифическое изображение

Для стереопары снимков аэрофотографической съемки создается анаглифическое изображение, которое можно наблюдать стереоскопически через двухцветные очки. Снимки должны содержать элементы ориентирования. Для создания этого изображения появляется окно, в котором необходимо указать:
-файлы левого и правого снимков,
-файл для записи изображения,
-сочетание цветовых фильтров для анаглифических очков,
-масштаб анаглифического изображения,
-нажать кнопку "Выполнить".
Программа определит зону перекрытия снимков стереопары и сформирует анаглифическое изображение этой зоны в эпиполярной системе координат. Изображение можно стереоскопически наблюдать через очки на мониторе с помощью любой программы просмотра растровых файлов или распечатать на цветном принтере или плоттере. При распечатке изображения 1:1 его масштаб будет близким к указанному при создании. Распечатанное изображение тоже можно наблюдать стереоскопически через анаглифические очки.


Обзор

Результаты ориентирования цифровой модели записываются в файл цифровой модели Models.ini, который находится в папке с пакетом програм "Дельта". В этих результатах указывается полный путь к файлам ориентируемых снимков. Кроме того результаты ориентирования записываются в файлы ориентируемых снимков. Таким образом достигается независимость созданной цифровой модели от файла цифровой модели. Однако иногда есть необходимость востановить элементы ориентирования из снимка в файл цифровой модели или загрузить элементы из файла модели в снимок.
В файле цифровой модели сохраняются данные всего процесса создания и ориентирования текущей цифровой модели. При переходе к созданию и ориентированию новой модели данные предыдущей модели (кроме элементов ориентирования) будут утеряны, что не позволит вернутся к работе с предыдущей моделью. Чтобы не повторять весь процесс создания и ориентирования предыдущей модели можно ее файл поместить в архив, а при необходимости снова вернуть в папку с пакетом программ.
В настоящем разделе приведено описание реализации обмена элементами ориентирования между файлом цифровой модели и растровыми образами снимков и создания архива файлов цифровой модели.

Окно программы содержит две панели:
· левая панель - для перемещения элементов ориентирования,
· правая панель - для формирования архива файлов цифровых моделей.


Перемещение элементов ориентирования

Перемещение элементов ориентирования реализовано на левой панели, которая содержит два списка:
· левый - список всех путей к снимкам, элементы ориентирования которых сохранены в текущем файле цифровой модели Models.ini,
· правый - список всех растровых файлов снимков в указанной папке, которые могут содержать элементы ориентирования.

Для каждого списка реализована множественная пометка элементов списка по правилам ОС Windows.

Под каждым списком находится одинаковый набор кнопок.

Для списка в Models.ini:

· Кнопка "В снимок". Предназначена для переноса элементов ориентирования с файла цифровой модели в растровые файлы снимков. Возможны 2 ситуации, в которых перенос элементов выполняется по разному.
1) Помечен только один элемент списка. При нажатии на кнопку элементы ориентирования переносятся в растровый файл, помеченный в правом списке. Если в право списке помечено больше одного элемента, то элементы ориентирования переносятся в активный элемент списка (находящийся в фокусе, содержащий курсор). Никакое сравнение имен файлов не выполняется. Этот способ позволяет элементы любого снимка в Models.ini переслать в любой растровый файл выбранной папки.
2) Помечены несколько или все элементы списка. В этом случае элементы ориентирования переносятся в те растровые файлы выбранной папки, имена которых совпадают с именами файлов в помеченных элементах левого списка. При этом сравниваются только имена файлов без учета полного пути доступа к ним.
Результаты переноса элементов ориентирования отображаются в выпадающем окне, где указывается источник, приемник и результат переноса.

· Кнопка "Пометить все" - для пометки всех элементов списка.

Примечание. При переносе элементов ориентирования в растровый файл переносятся некоторые характеристики фотокамеры (сдвиг главной точки, дисторсия). Программа использует камеру, имя которой записано в результатах ориентирования. Если камера с таким именем отсутствует в Models.ini, программа использует характеристики текущей(активной) камеры.

· Кнопка "Показать". В выпадающем окне отображаются элементы ориентирования активного элемента списка

· Кнопка "Удалить". Для удаления помеченных элементов списка. При отсутствии помеченных элементов удаляется активный элемент.

Для списка снимков в выбранной папке:

· Кнопка "В Models". Для переноса элементов ориентирования помеченных снимков в файл цифровой модели.

· Кнопка "Пометить все" - для пометки всех элементов списка.

· Кнопка "Показать". В выпадающем окне отображаются элементы ориентирования активного элемента списка

· Кнопка "Удалить". Для удаления помеченных элементов списка. При отсутствии помеченных элементов удаляется активный элемент.

Примечание. В элементах ориентирования, записаных в растровый файл, нет имени используемой камеры. При переносе элементов ориентирования в файл цифровой модели формируется строка Camera=Noname. При создании стереомодели с использованием таких элементов ориентирования необходимо правильно установить текущую камеру.

Над списком расположено поле отображения имени выбранной папки со снимками. Выбрать папку можно с помощью кнопки, расположенной правее поля. В списке отображаются все файлы с расширением .tif и имеющие структуру, позволяющую сохранять в них элементы ориентирования.


Формирование архива

Previous Top

Формирование архива файлов цифровой модели реализовано на правой панели. На ней расположен список INI-файлов, которые находятся в указанной папке. По умолчанию для архива определена папка с именем INIArchives, расположенная в папке с пакетом программ "Дельта". Если такой папки нет, программа ее создает сама. Над списком файлом расположено поле отображения имени папки, выбранной для архива. Кнопка правее этого поля позволяет выбрать любую папку для формирования архива.

Две кнопки ниже списка предназначены для переноса файлов.

· Кнопка "В архив". Предназначена для копирования текущего файла цифровой модели из папки с пакетом программ в папку, выбранную для архива. Программа выдает стандартный запрос для указания имени архивного файла. Расширение имени этого файла должно быть только .ini. При указании другого расширения программа изменит его на требуемое.

· Кнопка "Из архива". Предназначена для копирования помеченного в списке файла в текущий файл модели. Gthtl Перед копированием текущий файл цифровой модели можно скопировать в архив. Программа предупреждает, что текущий файл модели будет перезаписан. Кроме того, в папке с пакетом программ создается копия текущего файла цифровой модели с именем Models.ini.bak. При необходимости его можно снова переименовать в Models.ini.
·


DTM-File

 В процессе подготовки данных для ориентирования в файл цифровой модели заносится информация необходимая для ориентирования растровых образов. Файл цифровой модели называется MODELS.INI.