Введение

Данная программа входит в программный комплекс Digitals.

Программы комплекса Digitals защищены электронным ключом Guardant Hardlock. Вместе с ключом поставляется компакт-диск с программным обеспечением, на котором находятся драйвера ключа защиты. Перед установкой драйверов ключа защиты ознакомьтесь с инструкцией по установке – файл instdrv.txt. Для работы данного программного модуля в ключе должен присутствовать компонент Векторизация. В демо режиме имеется ограничение на количество сохраняемых объектов. Чтобы проверить какие компоненты содержит ваш ключ, выполните команду Помощь > О программе.


Назначение программы

Программа предназначена для векторизации сканированных изображений карт и планов и ориентирована, главным образом, на работу с картографическим материалом. Программа позволяет ускорить и упростить процесс сбора, заменив ручной режим сбора на полуавтоматическую векторизацию. При этом возможна векторизация следующих типов топографических объектов:

· Изолиний (или любые другие кривые).
· Контуров, состоящих из цепочки точек (контура растительности и лесов).
· Отметок высоты (при этом ищется центр окружности, обозначающей отметку и распознаются цифры на изображении, подписывающие значение отметки). Распознанное значение отметки высоты вводится в заданный оператором параметр.

Программа интегрирована с Digitals, позволяет открывать и сохранять файлы в формате Digitals DMF, а также передавать DMF файлы непосредственно в Digitals.


Идеология

Существует множество программ – векторизаторов (программ для перевода растровых изображений в векторное представление), предназначенных для широкого использования. Часто такие программы идут в комплекте с векторными редакторами. Эти программы могут перевести в векторную форму любой рисунок, но совершенно непригодны для работы с картографическим материалом. Связано это с тем, что при переводе в векторную форму не учитывается объектное построение изображения и векторизация происходит сразу для всего изображения.

Также существуют специализированные векторизаторы для использования с ГИС и САПР системами, но все они многофункциональны и сложны в использовании. Вам предлагается простая в использовании, быстрая и удобная программа для выполнения сбора картографических объектов и их начального редактирования. Векторизация всегда производится в полуавтоматическом режиме при полном контроле со стороны оператора. Все объекты на изображении векторизируются отдельно. Каждый объект записывается в указанный слой. Такой способ перевода изображения в векторную форму гарантировано сохраняет объектную структуру исходного изображения.

Количество действий по подготовке к векторизации сведено к минимуму, имея сориентированный растр его можно сразу открыть и приступить к векторизации.


Быстрый старт

Программа использует те же принципы создания и редактирования объектов, которые приняты в Digitals. Объекты разделяются по слоям, атрибутивные данные заносятся в параметры объекта. Если у вас имеется опыт работы с Digitals, изучить данную программу будет еще легче.

Этапы работы

Работа с программой состоит из 4-х основных этапов:

· Установка области трассировки.
· Сбор/векторизация.
· Редактирование.
· Назначение высоты изолиний.

Начинаем работу

Чтобы немедленно начать работу с программой выполните следующие действия:

1

Загрузите ориентированное растровое изображение.

2

Задайте область трассировки.

3

Перейдите в режим сбора/трассировки (клавиша <T>).

4

Выберите тип векторизируемых объектов из списка .

5

Выберите слой в который следует помещать собранные объекты.

6

Если установлен тип объектов векторизации – Отметки высоты, требуется еще задать параметр, в который будет заноситься распознанные на изображении значения высоты.

7

Если установлен тип объектов векторизации – Изолинии, включите Сглаживание и Генерализацию объектов при завершении сбора.

8

Установите порог отсечения по яркости, для отделения требуемых объектов на изображении от фона (клавиши <Pg Up> и <Pg Down>). При установке порога следите за глазом программы. Для отметок высоты, распознаваемыми на изображении объектами, являются цифры - значения высот отметок.

9

Включите автоматическую трассировку (клавиша <А>). Должен загореться зеленый индикатор в строке состояния.

10

Для изолиний укажите мышкой первую точку контура на изображении, затем вторую точку, которая задаст направление трассировки. При остановке трассировки на препятствии или обрыве укажите дальнейшее направление.

Для точечных контуров в начале также задайте 2 точки. При сборе указывайте именно точки контура, при этом по-возможности будет запускаться трассировка.

Для отметок высоты указывайте центры отметок. Однако, если отметка не сливается с фоном, можно указывать точку вблизи отметки, при этом программа сама найдет центр отметки.

11

Переключитесь в режим редактирования (клавиша <Е>) для перемещения/удаление/добавление точек, вставки разрывов, установки невидимой линии, для сглаживания и генерализации контуров, изменения порядка вывода объектов.

12

Присвойте значения высоты собранным изолиниям.

13

Сохраните результат работы в векторный формат Digitals DMF.

14

Передайте результат работы в Digitals, чтобы продолжить редактирование, используя более мощные средства Digitals.

Смотри также:

Создание пустого векторного файла

Открытие векторного файла

Установка порога яркости


Установка области трассировки

Перед трассировкой необходимо задать область трассировки.

Чтобы задать область трассировки нажмите кнопку [image] (Задать область трассировки) на панели инструментов. Эта кнопка стает доступной после открытия растра. Можно задать следующие области, выбрав соответствующий пункт из выпадающего меню:

· Весь растр.
· Полигон заданный опорными точками ориентирования.
· Произвольный выпуклый полигон.

Чтобы установить область трассировки - произвольный выпуклый полигон, выберите в выпадающем меню пункт Задать полигон и укажите вершины полигона мышкой. После указания последней вершины нажмите <F5> или выберите команду контекстного меню Замкнуть полигон. При этом, если отображение области трассировки было выключено, отображение включится и можно будет визуально оценить область трассировки.

При открытии растра автоматически задается область трассировки по опорным точкам ориентирования. Это справедливо для сканированных топографических карт, ориентирование которых выполнялось по углам рамки трапеции, но может быть ошибочным для остальных материалов. Поэтому после открытия растра следует проверять какая область трассировки установлена.

Чтобы увидеть, какая установлена область трассировки, включите отображение области трассировки (команда Вид > Область трассировки).

Смотри также:

Отображение области трассировки

Загрузка растрового изображения


Сбор/векторизация

После открытия растрового изображения, установки области трассировки и установки порога яркости можно переходить к векторизации/сбору объектов.

В процессе трассировки на сложных участках, векторизация может срабатывать неправильно (идти по ложному пути). Если такое происходит при правильно заданном пороге яркости, включайте ручной режим сбора (повторное нажатие клавиши <А>). Индикатор режима автоматической трассировки находится в строке состояния.

Чтобы продолжить сбор зарегистрированного объекта, включите Захват точек и линий и наведитесь мышкой на точку объекта, с которой требуется продолжить сбор. При щелчке по точке программа спросит, или следует продолжить выбранный объект, нажмите Да. Если была выбрана последняя точка, то порядок следования точек объекта меняется на противоположный. Если была выбрана точка между первой и последней, то объект будет продолжен через разрыв линии.

В зависимости от выбранного типа векторизируемых объектов, приемы работы при векторизации несколько отличаются.

Векторизация изолиний.

Укажите мышкой первую точку изолинии, затем вторую. Направление между первой и второй точками укажет программе направление изолинии. Если программа сможет векторизировать изолинию, вдоль ее контура будут добавлены точки с шагом трассировки, задаваемым в Сервис > Настройки.

Если на пути трассировки линия оборвется, пересечется другим объектом или изменится яркость линии или яркость фона, векторизатор остановится, предлагая указать направление для продолжения трассировки.

В режиме автоматической трассировки программа использует ручной сбор на тех участках, где автоматическая трассировка не запускается.

По окончанию векторизации/сбора изолинии нажмите клавишу <F5> или выберите команду Завершить объект из контекстного меню. При этом если включено сглаживание на панели трассировки/редактирования точки изолинии сразу будут сглажены. Если включена генерализация точки изолинии будут прорежены.

Для изолиний рекомендуется включать Сглаживание и Генерализацию на панели трассировки/редактирования. При этом сразу отсеиваются лишние точки, добавляются требуемые точки (в местах, где оператор «перешагнул» в ручном режиме), контур сглаживается, устраняются незначительные выбросы и шаг точек в итоге получается переменный и зависит от кривизны контура. Переменный шаг точек наиболее оптимально передает форму кривых (на прямых участках точек меньше чем на поворотах), при этом не перегружается векторный файл, увеличивается быстродействие, а точность передачи формы контура объекта не снижается.

Если собираемый объект был сглажен либо генерализирован ошибочно, не спешите собирать/векторизировать объект заново. Эти действия можно отменить командой Правка > Отмена.

Векторизация точечных контуров.

Для точечных контуров очень важно правильное задание порога отсечения. Выделенные по порогу яркости точки контура должны уверенно отделятся от фона и при этом сохранять форму близкую к окружности. Изображение должно иметь высокое разрешение (желательно не менее 400 dpi).

Векторизация производится так же как и векторизация изолиний, но указывать мышкой следует именно точки контура. Если автоматическая векторизация на данном участке невозможна, точки добавляются в режиме ручного сбора.

Векторизация отметок высоты.

Настройку уровня отсечения по яркости для отметок высоты следует выполнять по цифрам, обозначающих значение отметки. При правильной установке эти цифры не должны сливаться друг с другом или другими объектами на карте, но при этом не иметь разрывов. Иногда эти два условия одновременно не выполняются число может быть распознано неправильно, или не распознано вовсе. Изображение должно иметь высокое разрешение (желательно не менее 400 dpi).

Чтобы указать программе положение отметки высоты, щелкните в ее центр. Если кружок отметки хорошо виден, можно не целиться точно в центр кружка, программа сама отыщет его центр. Допускается даже непопадание указателем в кружок отметки.

Если значение отметки не распознано, или распознано неправильно, введите значение отметки вручную. Для этого, никуда не переключаясь, наберите правильное число на клавиатуре. Кнопка Отмена на панели трассировки/редактирования (или клавиша <Esc>) возвращает предыдущее значение при ошибочном вводе. Клавиша <Enter> завершает ввод. При вводе значения отметки не работают другие клавиши управления, чтобы выйти из режима ввода нажмите клавишу <Esc>.

Текст на изображении распознается с использованием эталонов символов.

Автоматическая векторизация точечных контуров и отметок высоты не работает для изображений в оттенках серого (черно-белых), так как для таких изображений обычно не получается отделить точки контура или цифры (высоту отметки) от других объектов. Если на вашем изображении точечные контура и цифры отметок не пересекаются с другими объектами, то ничего не мешает использовать это изображение для работы.

Смотри также:

Создание пустого векторного файла

Загрузка растрового изображения

Установка порога яркости

Сглаживание

Генерализация

Эталоны символов


Редактирование

После окончания векторизации/сбора всех объектов, или только части объектов приступают к их редактированию. Для этого переключитесь в режим редактирования (клавиша <Е> или кнопка [image] (Редактирование) на панели инструментов).

Наиболее частые операции при редактировании это изменение положения точек объекта, удаление и добавление точек.

Чтобы переместить точку объекта выделите его щелчком мыши вблизи контура объекта, подведите указатель и, нажав левую кнопку, перемещайте точку в нужную позицию. Текущие координаты курсора отображаются в правом нижнем углу. Кроме перемещения одной точки доступны также групповой режим перемещения и перемещение со сглаживанием. Если включен захват точек и линий (Правка > Захват точек и линий), при приближении курсора к точке или контуру объекта указатель мыши изменяется, показывая, что произошел захват.

Для добавления точки к выделенному объекту, удерживая <Ctrl>, подведите указатель мыши к месту на контуре объекта, где предполагается вставить точку. Когда указатель изменится на [image], нажмите левую кнопку мыши. К объекту будет добавлена точка, если при этом не отпускать кнопку мыши, добавленную точку можно сразу переместить.

Чтобы удалить точку выделенного объекта, удерживая <Ctrl>, подведите указатель мыши к точке и, когда вид указателя изменится на [image], нажмите левую кнопку.

Выделенные объекты можно перемещать целиком, для этого достаточно потянуть мышкой за центр выделения.

Возможно также перемещение, вращение, изменение размеров подписей.

Для перемещения подписи достаточно подвести указатель к центру подписи и удерживая левую кнопку поместить подпись в нужную позицию.

Для вращения подписи надо подвести указатель к левому нижнему углу подписи и удерживая левую кнопку мыши перемещать указатель.

Изменение размеров подписи аналогично вращению, только подводить указатель надо к одному из трех остальных углов подписи.

Допускается также редактирование или заполнение параметров объектов. Значения параметров выделенных объектов отображаются на закладке Редактирование на панели трассировки/редактирования.

Если выделено больше одного объекта, несовпадающие значения параметров будут отмечены символом *. После изменения параметра требуется нажать кнопку Применить под списком, иначе значение параметра изменено не будет.

Чтобы изменить слой выделенных объектов, используйте список слоев на закладке Редактирование на панели трассировки/редактирования или нажмите на кнопку [image] (Открыть...) для выбора слоя в отдельном окне.

При редактировании для просмотра протяженных объектов удобно использовать прокрутку экрана при вращении колесика мышки, для этого должно быть включено Следовать вдоль выделенного объекта при вращении колесика мышки в Сервис > Настройки.

Все изменения объектов, слоев, параметров обратимы. Чтобы вернуть или повторить изменения используйте сочетание клавиш <Ctrl – Z> и <Ctrl – R>, или кнопки [image] (Отмена) и [image] (Повтор) на панели инструментов.

Смотри также:

Панель трассировки/редактирования


Назначение высоты изолиний

Когда сбор и редактирование изолиний окончены, при помощи этой команды можно быстро назначать высоту сразу группе изолиний.

Чтобы назначить высоту изолиниям нажмите на кнопку [image] (Назначение высоты) на панели инструментов, затем:

· Проведите линию через изолинии, которым требуется назначить высоту. Проводите линию так чтобы не допускать повторного пересечения объектов.
· Откроется окно, в котором надо задать высоту первой изолинии и шаг изменения высоты (сечение)

· Если кроме изолиний на карте содержатся другие объекты надо определить слои в которых лежат изолинии, иначе высота будет назначена всем пересеченным объектам. Для этого отметьте галочкой Только для объектов из слоев и добавьте в список слои которые содержат изолинии.
· Нажимайте Выполнить. Объекты, которым была назначена высота будут помечены.

Чтобы визуально определить каким изолиниям высота не назначена, используйте Вид->Высотная раскраска, или Вид->Трехмерный.

Смотри также:

Высотная раскраска

Трехмерный вид


Файл

Новый | Создание пустого векторного файла.
Открыть... | Открытие векторного файла.
Сохранить... | Сохранение векторного файла.
Сохранить как... | Сохранение векторного файла под другим именем.
Выход | Завершение работы.


Новый

Файл > Новый

Создание пустого векторного файла

При создании нового файла на основе шаблона из шаблона загружается набор слоев, параметров и условных знаков.

По-умолчанию, в программе используется шаблон Normal.dmf, который должен находиться в каталоге с программой.

Если файл Normal.dmf не найден создается минимальный набор служебных слоев и параметров.

Редактируя Normal.dmf, или заменяя его, вы можете создавать для себя желаемый набор слоев, параметров и условных знаков который будет предлагаться по - умолчанию при создании нового файла.

Кроме шаблона Normal.dmf для создания нового файла можно использовать другие шаблоны.

Чтобы выбрать шаблон на основе которого будет создан новый файл используйте стрелку вправа от кнопки [image] (Создать) на панели инструментов.

Меню выбора шаблона
Меню выбора шаблона

Чтобы добавить свой шаблон в список шаблонов, поместите DMF файл в папку Templates, которая должна находиться в папке с программой.


Открыть

Файл > Открыть...

Открытие векторного файла

Программа открывает векторные файлы следующих форматов:

· ASCII -текстовый файл.
· DMF - родной формат векторных данных Digitals.

Программа имеет однооконный интерфейс, поэтому при открытии новый файл замещает текущий. Если имеются несохраненные изменения, программа предложит сохранить файл.

Смотри также:

Загрузка растрового изображения


Вид

Полный, Вектор, Растр | Переключение режимов просмотра.
Высотная раскраска | Режим отображения при котором цвет объектов зависит от их средней высоты.
Цвета высотной раскраски | Настройка режима высотной раскраски.
Трехмерный | Режим объемного отображения.
Область трассировки | Режим отображения области трассировки.
Тонкие линии без заливок | Режим чернового отображения
Показывать невидимые линии | Режим отображения невидимых линий
Показывать точки | Отображение точек для всех объектов карты
Уменьшить, Увеличить, Показать все | Управление масштабом отображения карты на экране.
Панель подсказок | Включение отображения панели подсказок.


Режимы просмотра

Вид > Полный (Вектор, Растр)

Переключение режимов просмотра

В программе предусмотрены следующие режимы просмотра:

· Полный - отображается растровое изображение и вектор.
· Вектор - отображается только вектор, если был открыт растр, он прячется.
· Растр - отображается только растр, если файл не пустой, все объекты прячутся.

Также на отображение влияют следующие команды

· Тонкие линии без заливок - отображение всех контуров линиями минимальной толщины, замкнутые объекты не заливаются (удобно для контроля топологии).
· Показывать невидимые линии - фрагменты линий, которым назначен статус невидимых отображаются и рисуются пунктиром.
· Показывать точки - включает отображени точек всех объектов (замедляет отрисовку).

Смотри также:

Высотная раскраска


Область трассировки

Вид > Область трассировки

Режим отображения области трассировки

Когда включено отображение области трассировки, часть изображения не попадающая в заданную область выводится в инверсных цветах.

Отображение области трассировки
Отображение области трассировки

Смотри также:

Установка области трассировки


Панель подсказок

Вид > Панель подсказок

Включение отображения панели подсказок

Используйте эту команду для включения панели подсказок.


На передний план (На задний план)

Правка > На передний план (На задний план)

Изменение порядка вывода объектов

Чтобы сделать видимыми объекты, закрываемые другими объектами, либо наоборот поместить объекты на задний план, используйте эту команду.

Изменение порядка вывода объектов
Изменение порядка вывода объектов


Выделение

Правка > Выделение

Различные способы выделения объектов

Для выделения объекта надо щелкнуть левой кнопкой мыши вблизи его контура.

Можно выделить все объекты или только объекты одного слоя.

Чтобы выделить объекты заданного слоя:

· Выделите объект, чтобы задать слой который будет использован для выделения объектов.
· Выполните команду Правка > Выделить весь слой.

Команды этой группы дублируются в контекстном меню в режиме редактирования а также на панели инструментов.


Выделенное в рамку

Правка > Выделенное в рамку

Установка рамки карты по помеченным объектам

Устанавливает рамку карты по размеру области выделенных в данный момент объектов.


Завхват точек и линий

Правка > Захват точек и линий

Включение/отключение захвата точек и линий

Включает режим захвата точек и линий. Во время захвата указатель меняет форму.

Радиус захвата определяется точностью карты, которую можно изменить в Сервис > Настройки.


Трассировка

Переключить порог | Переключение между сохраненными порогами яркости.
Запомнить порог | Запись текущего значения порога яркости в одну из ячеек.
Тип объектов трассировки | Выбор типа векторизируемых на изображении объектов.


Переключить порог

Трассировка > Переключить порог

Переключение между сохраненными порогами яркости

Переключаться между сохраненными порогами удобнее всего выполнять клавишами <1..4> на основной клавиатуре, при этом активная ячейка на панели трассировки/редактирования с сохраненным порогом будет подсвечена красным.

Смотри также:

Сохранение порога яркости


Тип объектов трассировки

Трассировка > Тип объектов трассировки

Выбор типа векторизируемых на изображении объектов

Программа позволяет векторизировать на изображении следующие типы объектов:

· Изолинии (или любые другие кривые).
· Точечные контура (контура растительности и лесов, состоящих из цепочки точек).
· Отметки высоты (пикеты).

Выбор типа векторизируемых объектов следует сделать перед векторизацией из выпадающего списка на панели трассировки/редактирования

Обычно каждому типу векторизируемых объектов соответствует свой слой. Чтобы связать тип векторизируемых объектов с соответствующим ему слоем используйте кнопку [image] на панели трассировки/редактирования. После связывания выбранный для каждого типа векторизируемых объектов слой будет менятся синхронно с переключением типа векторизируемых объектов.

Для Отметок высоты производится распознавание цифр на изображении, обозначающих значение высоты отметки. Распознанное значение записывается в параметр объекта, поэтому кроме указания слоя для отметок высоты надо указать параметр для записи распознанного значения.

Смотри также:

Панель трассировки/редактирования

Сбор и векторизация


Карта

Слои... | Редактирование атрибутов слоев.
Параметры... | Редактирование атрибутов параметров.
Свойства... | Информация о карте, изменение масштаба и координат рамки карты.
Эталоны символов... | Редактирование эталонов символов для распознования цифр и букв на изображении.
Передать в Digitals... | Загрузка открытой карты в Digitals.
Обновить из файла | Повторная загрузка карты из файла.


Слои

Карта > Слои...

Редактирование атрибутов слоев

В окне редактирования слоев можно:

· Изменять названия слоев

Для этого выполните двойной щелчок мышкой по строке с именем слоя или нажмите на кнопку [image] (Редактирование).
· Удалять слои

Для этого выделите слои для удаления и нажмите на кнопку [image] (Удалить выделенные).
· Редактировать список параметров доступных слою

Список доступных параметров определяет набор параметров из полного списка параметров карты, который будет доступен объектам данного слоя.

Чтобы редактировать список доступных слою параметров нажмите на кнопку [image] (Параметры слоя...). Откроется окно редактирования списка доступных слою параметров.
· Устанавливать тип слоя

Для этого выберите требуемый тип из списка Тип слоя.
· Изменять цвет и тип линии контуров объектов

Для этого используйте панель Линия.
· Изменять цвет и тип закраски замкнутых объектов

Для этого используйте панель Заливка.
· Изменять аттрибуты шрифта для типов слоя Таблица и Подпись

Для этого используйте панель Шрифт. Она становится доступной только при выделении слоев с типом слоя Таблица или Подпись.
· Устанавливать статус слоя

Для этого используйте панель Статус.

Тип слоя определяет тип объектов, которые ему принадлежат. Имеются следующие типы слоев:

· Группа слоев

Используется только для экспорта.
· Полигон/полилиния

Объекты этого слоя состоят из набора точек, соединенных прямыми линиями.
· Полигон/полилиния гладкая

Объекты этого слоя состоят из набора точек, соединенных плавными линиями (горизонтали).

· Пикет

Объекты этого слоя - точки с подписями (отметки высот, глубин).
· Одиночный символ

Объекты этого слоя - одиночные условные знаки (колодцы, столбы).

· Рамка и легенда

Служебный тип слоя, используемый для зарамочного оформления карт. Объекты этого слоя выводятся на печать независимо от заданной области печати.
· Таблица

Объекты этого слоя - текстовые таблицы с одной или несколькими колонками.
· Сетка ЦМР

Сетка высот, задающая модель рельефа.
· Разбивка на листы

Служебный тип слоя, используемый для задания области печати. Объекты этого слоя не выводятся на печать.
· Растровое изображение

Объекты этого слоя - вставленные в карту растровые изображения.
· Триангуляционная сеть

Нерегулярная сеть треугольников, задающая модель рельефа.
· Внедренный объект

Объекты этого слоя - вставленные в карту, при помощи технологии OLE, объекты созданные в других приложениях.
· Подпись

Объекты этого слоя - текстовые подписи.

Статус слоя определяет операции, которые можно с ним проводить а также его видимость: Имеются следующие состояния слоев:

· Правка

Разрешены все операции над объектами данного слоя.
· Пометка

Объекты данного слоя видимы и могут быть помечены, но не могут редактироваться.
· Видимый

Объекты данного слоя видимы, однако не могут ни помечаться, ни редактироваться.
· Скрытый

Объекты данного слоя не отображаются на карте и не могут ни помечаться, ни редактироваться.

Щелчок по заголовку списка слоев сортирует список. Сортировка возможна по: номеру, ID и названию.

Атрибуты можно менять сразу для нескольких выделенных слоев

При открытии окна редактирования слоев, активным слоем (выделенная строка в списке) устанавливается слой помеченного объекта. Кроме того, помечать объекты можно не закрывая окно редактирования слоев, при этом будет выделяться строка в списке слоев, соответствующая слою выделенного на карте объекта.

Смотри также:

Редактирование списка доступных слою параметров

Редактирование атрибутов параметров


Параметры

Карта > Параметры...

Редактирование атрибутов параметров

В окне редактирования параметров можно:

· Изменять названия параметров

Для этого выполните двойной щелчок мышкой по строке с именем параметра или нажмите на кнопку [image] (Редактирование).
· Удалять параметры

Для этого выделите параметры для удаления и нажмите на кнопку [image] (Удалить выделенные).
· Редактировать маску параметра

Для изменения маски параметра используйте выпадающий список

Если требуемой маски в списке не оказалось ее можно ввести вручную.

· Устанавливать тип параметра.

Для этого выберите требуемый тип из списка Тип параметра.
· Изменять цвет и тип линии границ подписей.

Для этого используйте панель Линия.
· Изменять цвет и тип закраски подписей.

Для этого используйте панель Заливка.
· Изменять атрибуты шрифта подписей.

Для этого используйте панель Шрифт.

· Устанавливать статус параметра.

Для этого используйте панель Статус.

Маска параметра -это строка, задающая формат вывода значения параметра. Для строковых параметров задает набор обязательных полей. Для числовых позволяет также выполнять простые арифметические действия. Примеры числовых масок:

Маска | Описание | Неформатированные значения | Форматированные значения
0.00 | Символ 0 обозначает обязательно заполняемый разряд в числовом значении. В данной маске 2 обязательных знака после разделителя. Если имеется числовое значение имеет более 2-х знаков после разделителя оно округляется. | 3.14157 25.104 1977 | 3.14 25.10 1977.00
0.## | Символ # указывает программе, что эти разряды заполняются только если цифра значащая (не ноль). В данной маске 2 необязательных знака после разделителя. | 3.14157 25.104 1977 | 3.14157 25.1 1977
/10000 0.0000 | Символ / обозначает что при форматировании значение параметра делится на 10000. Затем к результату применяется маска 0.0000 - округление до 4-х знаков после разделителя, все позиции обязательны к заполнению. | 25000 999 | 2.5000 0.0999

Маски строковых параметров здесь не рассматриваются.

Тип параметра определяет тип значений, которые он хранит. Имеются следующие типы параметров:

· Целое 8, 16, 32,

Целочисленные значения. Отличается длиной 8, 16 и 32 байта.
· Вещественное

Вещественные (дробные) числа.
· Строка

Текстовые строки.

· Логическое

Логические значения (Истина/Ложь).
· Файл

Ссылки на внешние файлы.

· Список

Список заранее определенных значений.
· Таблица

Список значений из нескольких колонок.

Статус параметра определяет операции, которые можно с ним проводить а также его видимость: Имеются следующие состояния параметров:

· Правка

Разрешены все операции над параметром.
· Пометка

Подписи данного параметра видимы и могут быть помечены, однако не могут редактироваться.
· Видимый

Параметры видимы, однако не могут ни помечаться, ни редактироваться.
· Скрытый

Подписи данного параметра не отображаются на карте и не могут ни помечаться, ни редактироваться.

Щелчок по заголовку списка параметров сортирует список. Сортировка возможна по: номеру, ID и названию.

Атрибуты можно менять сразу для нескольких выделенных параметров.

Смотри также:

Редактирование атрибутов слоев


Передать в Digitals

Карта > Передать в Digitals...

Загрузка открытой карты в Digitals

Используйте эту команду чтобы передать редактируемую карту в Digitals для расширенного редактирования.

При передаче в Digitals файл автоматически сохраняется, запускается Digitals и в его окне открывается переданная карта.

По-умолчанию, запускается исполняемый файл ассоциированный с DMF файлами, если вы желаете изменить путь к Ged.exe (исполняемый файл Digitals) укажите путь к нему в Сервис > Настройки.

Данная команда в паре с командой Обновить из файла позволяют работать над одним файлом одновременно в Topotracer и Digitals.

В старых версиях Digitals при повторной передаче файла, если он уже открыт в окне Digitals, обновление карты в Digitals не произойдет. Чтобы открытая карта обновилась при передаче закройте ее в Digitals и повторите команду передачи.

Смотри также:

Обновить из файла


Растр

Открыть... | Загрузка растрового изображения.
Закрыть | Закрытие растрового изображения.


Открыть

Растр > Открыть...

Загрузка растрового изображения

Растровое изображение используется в качестве подложки для сбора и векторизации. Это должен быть скан бумажной карты или схемы.

В программу можно загрузить предварительно сориентированное изображение, но допускается загрузка и изображений без ориентирования. Если данные ориентирования не будут найдены выдается соответствующее предупреждение и векторные координаты точек полученных при трассировке будут соответствовать точкам растра (начало отсчета - левый нижний угол, ось Х направлена вверх, ось Y вправо).

Программа считывает данные ориентирования из следующих источников (в указанном порядке):

· Models.ini (ориентирование при помощи программы Models)
· World файл (текстовый файл с расширением совпадающим с расширением файла растра плюс буква w)
· TAB файл (файл получаемый при регистрации растра в MapInfo)
· Заголовок TIF файла (ориентирование при помощи AutoOrient либо Models)

Путь к файлу Models.ini задается в Сервис > Настройки - путь к папке Digitals.

Для ориентирования изображения используйте программу Models из комплекса программ Digitals, либо утилиту пакетного ориентирования AutoOrient.

Рекомендуется использовать формат растрового файла TIFF Tiled, желательно с пирамидой масштабов. Растры в данном формате не загружаются целиком в оперативную память, что позволяет работать с большими изображениями.

Если перед открытием растра вы открыли векторный файл, или выполняли сбор, то после открытия растра может появиться сообщение Слишком большой размер рамки, рамка установлена по растру, часть или все объекты могут оказаться за рамкой. Рамка в данной программе задает диапазон координат карты, а область за рамкой недоступна. При открытии растра рамка расширяется так чтобы захватить все углы растра. Однако при большом расхождении координат текущей рамки и координат углов растра размер рамки может оказаться слишком большой, что недопустимо. Если такое случается, выдается соответствующее предупреждение и рамка устанавливается по углам растра. Объекты не исчезают, они просто могут оказаться за рамкой и быть недоступными. Чтобы установить рамку по объектам выполните команду Карта > Свойства > Все объекты в рамку.

После открытия растра надо проверить и при необходимости установить область трассировки. Чтобы увидеть, какая область трассировки задана, включите отображение области трассировки (команда Вид > Область трассировки).

Смотри также:

Открытие векторного файла

Установка области трассировки

Отображение области трассировки


Сервис

Линии в полосы | Преобразование выделенных полилиний в полосы заданной ширины.
Настройки... | Настройки программы.


Линии в полосы

Сервис > Линии в полосы

Преобразование выделенных полилиний в полосы заданной ширины

Используйте эту команду чтобы быстро создавать полосы заданной ширины. Например, при сборе дорог или для задания областей видимости/невидимости.

Полоса представляет собой замкнутый полигон заданной ширины. Ширину полосы можно задавать в мм на бумаге и метрах на местности.


Панель инструментов

Содержит наиболее часто используемые команды.

Смотри также:

Главное меню


Панель трассировки/редактирования

Содержит элементы управления трассировкой и список параметров.

    Панель трассировки
Панель трассировки
Панель редактирования
Панель редактирования

Смотри также:

Сбор/векторизация

Редактирование


Строка состояния

Служит для отображения дополнительной информации.


Горячие клавиши

Список клавиатурных сокращений, ускоряющих работу с программой:

Ctrl-O | Открытие векторного файла
Ctrl-S | Сохранение векторного файла.
Ctrl-Z | Отмена последней операции.
Ctrl-R | Повтор последней операции.
Ctrl-U | Сглаживание контуров выделенных объектов.
Ctrl-W | Показать все объекты карты.
Ctrl-A | Выделить все объекты карты.
Back Space, F8 | Удалить последнюю точку при сборе/векторизации.
Delete | Удалить выделенные объекты.
Shift | Включение режима перемещения рукой.
A | Переключение ручной/автоматической трассировки. Индикация в левом нижнем углу в строке состояния.
E | Переключение в режим редактирования.
T | Переключение в режим трассировки.
+ | Увеличить.
- | Уменьшить.
F2 | Невидимая линия отсюда при сборе/векторизации.
F3 | Замкнуть объект при сборе/векторизации.
F4 | Разрыв контура объекта при сборе/векторизации.
F5 | Завершить объект при сборе/векторизации.
Pg Up, Pg Down | Увеличить/уменьшить пороговый уровень яркости при открытом растре.
Ctrl 1..4 | Сохранить текщее значение порога яркости в одну из 4-х ячеек.
1..4 | Применить сохраненное в одной из 4-х ячеек значение порога яркости.


Установка порога яркости

Значение порога яркости используется для выделения векторизируемых объектов на изображении.

Чтобы установить порог яркости используйте клавиши <Pg Down> и <Pg Up>, или ползунок на панели трассировки/редактирования.

Для визуального контроля правильности установки порога яркости используйте глаз программы на панели трассировки/редактирования. В нем зеленым цветом рисуются выделенные отсечением по яркости объекты. Это та часть изображения, которую видит векторизатор.

Также при изменении порогового уровня выделенные по порогу яркости точки изображения рисуются зеленым прямо под курсором мыши.

Это удобно для точной установки значения порога. Порог следует устанавливать таким образом, чтобы выделенные точки изображения накрывали почти всю площадь векторизируемого объекта, за исключением небольшой границы по контуру. Если зеленым показываются также точки фона – уменьшайте порог отсечения (клавиша <Pg Down>).

Признаком неверно выставленного порога отсечения являются неправильные срабатывания векторизатора, когда трассировка ведется по ложному пути, или векторизация не запускается или запускается редко.

Так как фон изображения, а также яркость векторизируемых объектов обычно неодинаковы для всей площади растра, необходимо постоянно подстраивать порог. Чтобы ускорить этот процесс, в программе предусмотрена возможность запоминать текущее значение порога в одну из 4-х ячеек на панели трассировки/редактирования.